Go Back   MustangForums.com > Search Forums
Sign in using an external account
Register Forgot Password?
Search


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Showing results 1 to 7 of 7
Search took 0.02 seconds.
Search: Posts Made By: ricmarcarp
Forum: Classic Mustangs (Tech) 10-22-2014, 05:45 PM
Replies: 7
Views: 398
Posted By ricmarcarp
They have tried changing plugs, plug wires,...

They have tried changing plugs, plug wires, checked timing, even different dist., and carb. Idles fine until it begins to warm up, then spits and sputters. Also different coil. Compression also is...
Forum: Classic Mustangs (Tech) 10-22-2014, 09:35 AM
Replies: 7
Views: 398
Posted By ricmarcarp
351 cleveland problems

Was driving my 69 Mustang with 351 Cleveland, when within a span of about 6 or 7 miles, it went from running fine, to a slight miss, to totally undrivable. Have had it to two different places (one...
Forum: Michigan Regional Chapter 06-08-2013, 08:27 AM
Replies: 1
Views: 293
Posted By ricmarcarp
Angry need help with cleveland

Have a 69 grande with a 1971 cleveland engine that was rebuilt 4 years ago. Only drive it from mid april - mid oct. Take it in for tune-up & oil every spring. This year after the usual spring...
Forum: Classic Mustangs (Tech) 05-18-2013, 06:56 PM
Replies: 6
Views: 484
Posted By ricmarcarp
Yes, it does it when I cruise, took it back to...

Yes, it does it when I cruise, took it back to the shop and they are going to check the
carb on Monday.
Forum: Classic Mustangs (Tech) 05-18-2013, 01:51 PM
Replies: 6
Views: 484
Posted By ricmarcarp
it runs strong & sounds great until you let up on...

it runs strong & sounds great until you let up on the gas
Forum: Classic Mustangs (Tech) 05-18-2013, 01:48 PM
Replies: 6
Views: 484
Posted By ricmarcarp
not a problem in neutral, haven't really checked...

not a problem in neutral, haven't really checked the rpms when this is happening, all this started when I took it in for a tune-up a couple of weeks ago.
Forum: Classic Mustangs (Tech) 05-17-2013, 09:06 PM
Replies: 6
Views: 484
Posted By ricmarcarp
Angry sputtering cleveland

have a 69 grande with a Cleveland motor that runs good as long as your pushing the gas pedal, if you ease up, it starts to run rough. idles fine, any ideas?
Showing results 1 to 7 of 7

 
Forum Jump
Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 09:22 PM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup