Go Back   MustangForums.com > Search Forums
Sign in using an external account
Register Forgot Password?
Search


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Showing results 1 to 6 of 6
Search took 0.02 seconds.
Search: Posts Made By: t3ch
Forum: 4.6L V8 Technical Discussions 08-12-2014, 02:43 PM
Replies: 4
Views: 434
Posted By t3ch
I didn't manage to reach SCT so far(called a few...

I didn't manage to reach SCT so far(called a few times and I left a voicemail)
Yes I verified the tuner works for my car, it also detect my car properly.
Forum: 4.6L V8 Technical Discussions 08-12-2014, 09:30 AM
Replies: 4
Views: 434
Posted By t3ch
Yes the car runs perfect without the tune. No...

Yes the car runs perfect without the tune. No it's not a custom tune it's the SCT strategy tune which for the moment I was selecting the stock airbox as intake (until I get my CAI).
Forum: 4.6L V8 Technical Discussions 08-11-2014, 04:39 PM
Replies: 4
Views: 434
Posted By t3ch
SCT tuner strategy tune causing detonation

Hi all,
I recently got an SCT tuner and I am waiting to get a cold air intake as well. I installed the strategy tune with 87 octane in the meantime to get the cold air intake so I can see how it...
Forum: 2005 - 2014 Mustangs 08-11-2013, 08:29 PM
Replies: 74
Views: 4,166
Posted By t3ch
wing

I find it looks much better than the stock one..., i'd go for it
Forum: 4.6L V8 Technical Discussions 08-11-2013, 04:05 PM
Replies: 14
Views: 1,304
Posted By t3ch
Shaker 1000 with aftermarket headunit

I was wondering how you have fit the sub and amps of the shaker 1000 with your aftermarket head unit? I have a shaker 1000 too and been thinking of getting a new head unit mainly for aux/usb in and...
Forum: 4.6L V8 Technical Discussions 08-10-2013, 08:18 PM
Replies: 10
Views: 1,144
Posted By t3ch
Same problem

Hi,
I am having the same problem on my GT 2005 manual too, it does it only when the engine is cold and I noticed that if I turn off the engine and turn it on again it goes away. If anyone got this...
Showing results 1 to 6 of 6

 
Forum Jump
Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 05:11 AM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup