Go Back   MustangForums.com > Search Forums
Sign in using an external account
Register Forgot Password?
Search


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Showing results 1 to 25 of 80
Search took 0.03 seconds.
Search: Posts Made By: JBeachstang11
Forum: 5.0L General Discussion 11-22-2014, 10:07 AM
Replies: 92
Views: 4,345
Posted By JBeachstang11
Alright, little update here. - I made my...

Alright, little update here.

- I made my starter grind/screech much better by forcing the starter towards the flywheel as I tightened the bolts. Makes a case for slottin the holes a small amount....
Forum: 5.0L General Discussion 11-14-2014, 04:28 PM
Replies: 9
Views: 405
Posted By JBeachstang11
Well if you happen to take a trip to N Fla in a...

Well if you happen to take a trip to N Fla in a truck/suv sometime soon toss it in there and we'll talk turkey,:icon_beerchug:

Meanwhile in stupidsville - I had to massage my 90 fender quite a bit...
Forum: 5.0L General Discussion 11-14-2014, 08:17 AM
Replies: 92
Views: 4,345
Posted By JBeachstang11
Cool man! Sure PM me about it. Thanks. ...

Cool man!

Sure PM me about it. Thanks.

edit: Just noticed you're in WV, never mind lol..
Forum: 5.0L General Discussion 11-13-2014, 11:22 PM
Replies: 92
Views: 4,345
Posted By JBeachstang11
Mostly done with my Cobra 5 lug swap, just have...

Mostly done with my Cobra 5 lug swap, just have the hard lines/adj prop valve and MM stainless lines up front. Rears are just 5 lug drums for now..

Also just found out my car has a 1984 Capri T5...
Forum: 5.0L General Discussion 11-11-2014, 07:57 AM
Replies: 92
Views: 4,345
Posted By JBeachstang11
Awesome, thank you. I have all the pin out...

Awesome, thank you. I have all the pin out diagrams as well so locating the wires shouldn't be an issue. Will be interesting to see if there is a difference between the meters and the readouts in the...
Forum: 5.0L General Discussion 11-10-2014, 10:27 PM
Replies: 92
Views: 4,345
Posted By JBeachstang11
Man that's great info. I need to backprobe mine...

Man that's great info. I need to backprobe mine just like that but still deep in my cobra brake swap. Once through that I'll check my 02's at the comp like you did. My innovate WB instructions...
Forum: 5.0L General Discussion 11-08-2014, 10:35 AM
Replies: 92
Views: 4,345
Posted By JBeachstang11
Here's the car with the Borla Pro XS mufflers in...

Here's the car with the Borla Pro XS mufflers in and LX style tailpipes. Bit more subdued than the 2 Chamber Flows but still loud..

Borla Pro XS - YouTube
Forum: 5.0L General Discussion 11-07-2014, 07:35 PM
Replies: 92
Views: 4,345
Posted By JBeachstang11
Hope to do my cobra brake/5 lug swap tomorrow...

Hope to do my cobra brake/5 lug swap tomorrow then nail down this lean issue.

Be interested to hear your progress also.
Forum: 5.0L General Discussion 11-07-2014, 04:55 PM
Replies: 92
Views: 4,345
Posted By JBeachstang11
Still running lean at idle, 22ish.. but drops to...

Still running lean at idle, 22ish.. but drops to 13/14/15 when I blip the throttle. So thinking still the cam possibly.

Problem is it that cruising around it seems way lean 18-20ish even when I'm...
Forum: 5.0L General Discussion 11-07-2014, 12:21 PM
Replies: 9
Views: 405
Posted By JBeachstang11
Excellent, will be absorbing that all. Thanks...

Excellent, will be absorbing that all. Thanks again mjr46.
Forum: 5.0L General Discussion 11-07-2014, 11:49 AM
Replies: 9
Views: 405
Posted By JBeachstang11
Absolutely, good point. "Pecker tracks".....

Absolutely, good point.

"Pecker tracks".. Haha love it..
Forum: 5.0L General Discussion 11-07-2014, 11:40 AM
Replies: 9
Views: 405
Posted By JBeachstang11
Ok I'll try that as well. I post a pic too so you...

Ok I'll try that as well. I post a pic too so you can see clearly. PO did add a section of wire to the end of the green/tan wire with a butt connector into the relay, weird..

Just doesn't make...
Forum: 5.0L General Discussion 11-07-2014, 10:11 AM
Replies: 9
Views: 405
Posted By JBeachstang11
1990 GT "High Current Fuel Pump Circuit"constant 12vdc

I tried to search but couldn't find a thread about this.

I was trying to diagnose a code 96 and was checking the FP relay voltages and found a constant 12.65v on green/tan wire(high current...
Forum: 5.0L General Discussion 11-06-2014, 06:02 PM
Replies: 92
Views: 4,345
Posted By JBeachstang11
Swapped mufflers and tailpipes tonight, also...

Swapped mufflers and tailpipes tonight, also replaced the fuel pump.

Haven't run the car - too late..

Did test fuel pressure just with key, motor off and instantly noticed a huge change....
Forum: 5.0L General Discussion 11-06-2014, 10:04 AM
Replies: 92
Views: 4,345
Posted By JBeachstang11
Video of a short cruise. Not really smoking...

Video of a short cruise. Not really smoking anymore. Will surge for a minute or so when I start it then seems to settle out. Still need to datalog with the innovate stuff and wire it in to the EGR.
...
Forum: 5.0L General Discussion 11-05-2014, 09:27 AM
Replies: 92
Views: 4,345
Posted By JBeachstang11
Mine is N/A. Checkin my fuel pump wiring and...

Mine is N/A.

Checkin my fuel pump wiring and relay circuit - 1990year, My #4 wire green/tan (high current circuit) has constant 12.65v with key off then drops to 12.4 with key on. Should be 0 with...
Forum: 5.0L General Discussion 11-04-2014, 02:32 PM
Replies: 92
Views: 4,345
Posted By JBeachstang11
Hahaha.. Very good!

Hahaha.. Very good!
Forum: 5.0L General Discussion 11-04-2014, 09:56 AM
Replies: 92
Views: 4,345
Posted By JBeachstang11
My gawd.. Yeah that would get a little out of...

My gawd.. Yeah that would get a little out of hand quickly. Maybe pull some boost to keep everything happy for now? Ha, not exactly a fun idea..
Forum: 5.0L General Discussion 11-04-2014, 08:03 AM
Replies: 92
Views: 4,345
Posted By JBeachstang11
Our lifts are basically the same, like you said...

Our lifts are basically the same, like you said my duration is just a bit more than yours. Be interesting if anyone else in here could chime in with their cam/WB readings.

I'll be interested to...
Forum: 5.0L General Discussion 11-03-2014, 12:26 PM
Replies: 92
Views: 4,345
Posted By JBeachstang11
Interesting man. As I understand it big cams will...

Interesting man. As I understand it big cams will cause Widebands to read lean at idle from all the fresh air during overlaps. I know you mentioned your compression previously but not cam setup.
...
Forum: 5.0L General Discussion 11-02-2014, 11:09 PM
Replies: 92
Views: 4,345
Posted By JBeachstang11
Preliminary findings after checking those things....

Preliminary findings after checking those things. Car starts and runs 100% better. Still had a hint of smoke but it is cut down massively. Took a short drive around today, couldn't even do that...
Forum: 5.0L General Discussion 10-18-2014, 04:07 PM
Replies: 92
Views: 4,345
Posted By JBeachstang11
Man tell me about it. I've had a a few moments I...

Man tell me about it. I've had a a few moments I was going to sell the car or part it out. Getting to that point but I know I am right at the point of being able to enjoy it once this programming is...
Forum: 5.0L General Discussion 10-16-2014, 12:21 PM
Replies: 92
Views: 4,345
Posted By JBeachstang11
Thanks for that, much appreciated! ...

Thanks for that, much appreciated!



See this is what I wonder as well because it starts and sounds great until after a few mins then almost like it is switching to a different map (I'm still...
Forum: 5.0L General Discussion 10-15-2014, 06:28 PM
Replies: 92
Views: 4,345
Posted By JBeachstang11
LC-2 Wideband installed and calibrated. Ran...

LC-2 Wideband installed and calibrated.

Ran car from a cold start and wideband shows 18-22 AFR while Bin Ed 2012 dash is showing 12-14ish..

Car still began to smoke after 5 min.
Forum: 5.0L General Discussion 10-15-2014, 11:47 AM
Replies: 34
Views: 2,212
Posted By JBeachstang11
Good job on the Notch and congrats on new job,...

Good job on the Notch and congrats on new job, more pay and new 5.0!!:icon_steer:
Showing results 1 to 25 of 80

 
Forum Jump
Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 07:07 PM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup