MustangForums.com - Search Results

Go Back   MustangForums.com > Search Forums
Sign in using an external account
Register Forgot Password?
Search


Showing results 1 to 3 of 3
Search took 0.01 seconds.
Search: Posts Made By: mcan6
Forum: V6 (1994-2004) Mustangs 07-04-2014, 03:32 PM
Replies: 3
Views: 626
Posted By mcan6
Its looking like the transmission fluid is gonna...

Its looking like the transmission fluid is gonna need to be flushed and I'm gonna get a new filter also. If that doesn't work I will consider what you described. Thanks for the reply.
Forum: V6 (1994-2004) Mustangs 07-03-2014, 10:17 AM
Replies: 3
Views: 626
Posted By mcan6
Another thing to add.

Was told by a friend that the transmission filter might need to be replaced. Could this be the cause?
Forum: V6 (1994-2004) Mustangs 07-03-2014, 09:29 AM
Replies: 3
Views: 626
Posted By mcan6
Slow acceleration after coming to a stop.

After coming to a complete stop, the car is slow to get up and going again. Even lifting off the brake doesnt get it moving. Once I get to about 25 mph it drives very smoothly. Thought it could be...
Showing results 1 to 3 of 3

 
Forum Jump
 
Advertising
Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 05:52 AM.>

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup