possible map sensor issue? - MustangForums.com

Go Back   MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang > Speed Density/Carb/SSP section

Speed Density/Carb/SSP section This section is for the Speed Density or Carb vehicles, as well as Special Service Package 'Stangs

possible map sensor issue?

Thread Tools Search this Thread
Old 07-14-2015, 09:12 PM   #1
86 newbie
2nd Gear Member
86 newbie's Avatar
Join Date: Aug 2010
Vehicle: 1986 ford mustang gt
Location: ohio
Posts: 248
Default possible map sensor issue?

Ok so i have a 86 5.0 i just got done putting ported e7 heads on, a cobra upper and lower intake, and an x-303 cam in it. When the map vacuum line is on the idle shoots way up to about 2500 but doesnt miss or anything. When i take the vacuum line off it idles back down but starts running rich and misses bad. Is there anyway to fix the sensor for the cam? Is there anything i can do? The tps sensor is also on .9, tomorrow i need to make the holes bigger so i can adjust it more closer to .97. The lobe separation angle on the cam also is 112. Thanks for any info.
86 newbie is offline   Reply With Quote
Old 08-16-2015, 09:26 PM   #2
mjr46's Avatar
Join Date: Jun 2007
Vehicle: 85 mustang
Location: West Virginia
Posts: 30,595

it'll never run right with that cam on speed density.......requires mass air if you don't already have it converted.....if converted no line should be hooked to map...map becomes bap...........check for vac leaks

Originally Posted by EUTARD View Post
Suggest having a conversation with the highly INEXPERIENCED clowns....D.R the Dork, THE BarnyYard smells like......again and finally staring the highly intelligent and I must say skilled Eutard! UH where did de' go George
mjr46 is offline   Reply With Quote
Old 08-17-2015, 06:59 AM   #3
5th Gear Member
Join Date: Jul 2012
Vehicle: 1990 lx hatch 5.0
Location: ohio
Posts: 2,968

MAF conversion, only way youll get the thing to idle correctly, your not pulling enough vacuum on the map with that cam.
dawson1112 is offline   Reply With Quote
Old 08-17-2015, 08:30 AM   #4
88 orangepeel notch
5th Gear Member
88 orangepeel notch's Avatar
Join Date: Mar 2010
Vehicle: 1988 notchback
Location: Wisconsin
Posts: 3,405

And don't touch your TPS, it's fine where it is.
306 with all bolt ons, letter cam, ported E7's, T5 swap, full exhaust, 3:55's, 2" drop, and the worst paint you'll ever see or feel.
Dyno'd 300/316, 2745lbs-track scale
Best ET………12.4@108, 1.66 60ft on 8" ET Drags.

88 orangepeel notch is offline   Reply With Quote


Similar Threads
Thread Thread Starter Forum Replies Last Post
Code troubleshooting Jb145700 4.6L V8 Technical Discussions 8 09-24-2015 05:08 PM
O2 sensors Big Al's 03 Mach 1 Section 4 09-21-2015 08:59 AM
All 10-14' Mustangs w/ Sync Raxiom Navigation Unit - Not Working - yourmom6990 Parts For Sale 2 09-14-2015 11:52 PM
OBD: The Adventure Begins (PO402 and PO401), DPFE/EGR test procedures TfcCDR V6 (1994-2004) Mustangs 1 09-14-2015 01:08 PM
Huge Savings from Lethal Performance.com!(Whipple, McLeod, Kooks, & MUCH MORE..) Boostaddict Lethal Performance 2 09-08-2015 10:56 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 09:42 PM.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company