Search



Go Back   MustangForums.com > Ford Mustang Tech > Tuner Central
Sign in using an external account
Register Forgot Password?
Search

Tuner Central Have a question about which hand tuner is best for your Mustang? Talk about it here!
Sponsored by Diablo Sport
Click Here

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 06-30-2014, 10:40 PM   #1
Gadgetech
1st Gear Member
 
Gadgetech's Avatar
 
Join Date: Nov 2009
Vehicle: 2001 Ford Mustang GT Vert
Location: SC
Posts: 126
Default SCT Device updater won't see X4

I'm beyond frustrated with tuning devices in general, they never are plug and play.
  • Running Windows 8 Pro
  • Updated X4
  • Updated Device Updater Software running vs. 2.9.8.90
  • Device updater won't connect to the X4
  • Tried both USB ports
  • Verified device driver installed and showing X4 communication


Still won't connect. I even tried running it on a virtual instance of Windows 7 Pro that I use to run the tuning software for my motorcycle. I swear this tuning stuff is going to send me running into the hills screaming and pulling my hair out. Any ideas on how to get this thing working so I can upload the custom tune I paid for to my Mustang? Why can't this S#!t be simple?
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
__________________

Member #128
Gadgetech is offline   Reply With Quote
Old 07-07-2014, 08:36 PM   #2
ticopowell
2nd Gear Member

 
Join Date: Sep 2012
Vehicle: 2013 Ford Mustang
Location: California
Posts: 299
Default

Have you tried a different computer? if not then try that. If that doesn't work I would call SCT and have them either fix it, or send you a new one. Or call the people that you bought it from.
ticopowell is offline   Reply With Quote
Old 07-24-2014, 09:39 PM   #3
Gadgetech
1st Gear Member
 
Gadgetech's Avatar
 
Join Date: Nov 2009
Vehicle: 2001 Ford Mustang GT Vert
Location: SC
Posts: 126
Default

I ended up getting with SCT. They did a remote session and downloaded some drivers that did not download with the software and all works well now on my W8 machine.
__________________

Member #128
Gadgetech is offline   Reply With Quote
Old 07-24-2014, 09:39 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 02:31 AM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup