MustangForums.com

MustangForums.com (http://mustangforums.com/forum/index.php)
-   V6 (1994-2004) Mustangs (http://mustangforums.com/forum/v6-1994-2004-mustangs-4/)
-   -   Gauge Sweep and warning lamps flash while Driving (http://mustangforums.com/forum/v6-1994-2004-mustangs/697764-gauge-sweep-and-warning-lamps-flash-while-driving.html)

GoldMustangV6 07-05-2013 10:19 PM

Gauge Sweep and warning lamps flash while Driving
 
Ok so I have an 02 3.8 v6 with this problem. It started a couple days after i installed a new amp and sub in the car. There was existing wires ran already for a system that was previously installed. Everything was working great for a day or so. Then while driving down the road my gauges sweep and all of the warning lights in the dash flash. The headlights also turn off and the car feels like it is being jerked. I am stumped on this, i have looked all over and found no info. Please help Me this is annoying as H***!

Daehawk 07-06-2013 12:47 AM

Loose connection somewhere. Id start with the battery cables and car ground.

BabyGT 07-06-2013 01:04 AM

Yep, or the amp you installed is drawing more power than the alt can produce during particularly hard hitting bass notes.

GoldMustangV6 07-06-2013 01:35 AM

Thanks for the suggestions guys. I checked the battery terminals and they seemed tight although they are pretty corroded. As for the ground, is that connected to the fire wall? And where could I find it. I'm a complete beginner on most vehicle knowledge. The amp that was on before used a 30a fuse, the one I have now uses a 50a fuse, would that make a difference? Thanks again


All times are GMT -5. The time now is 06:30 PM.