Go Back   MustangForums.com > Ford Mustang Tech > V6 (1994-2004) Mustangs
Sign in using an external account
Register Forgot Password?
Search


V6 (1994-2004) Mustangs Technical discussions on the 3.8L and 3.9L V6 torque monsters
Sponsored by Optima Batteries


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 04-11-2014, 02:14 AM   #1
Natenqstang
 
Join Date: Nov 2011
Vehicle: 2000 Ford Mustang V6
Location: California
Posts: 11
Nathanael.quintanar
Default Help!!!

So yesterday my 2000 v6 mustang started to shake as if gas wasn't going by or as if it was in 5th while going 20mph. Then I noticed some weird screeching noise when It was put in gear.
So today it really started shaking and the car turned off as if I stalled. Which I couldn't because it's an automatic 😔.
Not sure if it's the transmission, a misfire, or the fuel filter.
Help please.
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
Natenqstang is offline   Reply With Quote
Old 04-11-2014, 08:36 AM   #2
BabyGT
5th Gear Member
 
BabyGT's Avatar
 
Join Date: Mar 2012
Vehicle: 2004 3.9 Vert & 1994 5.0 Vert
Location: Virginia
Posts: 2,038
X757XVeritas
Default

Check engine light come on? When's the last time you had or changed the oil yourself? Spark plugs ever been changed? Positive you have gas? Ever changed the fuel filter/air filter?
__________________


04 3.9l Convertible- Daily driver
94 5.0l Convertible- Work in progress
92 5.0l Hatchback- Another work in progress
BabyGT is offline   Reply With Quote
Old 04-11-2014, 10:44 AM   #3
Natenqstang
 
Join Date: Nov 2011
Vehicle: 2000 Ford Mustang V6
Location: California
Posts: 11
Nathanael.quintanar
Default

No check engine light. I changed the oil like 3 months ago.
Spark plugs have not been changed in almost 4 years. Damn.
I filled up the tank the day before. Fuel filter was changed last year.
Natenqstang is offline   Reply With Quote
Old 04-11-2014, 10:45 AM   #4
Natenqstang
 
Join Date: Nov 2011
Vehicle: 2000 Ford Mustang V6
Location: California
Posts: 11
Nathanael.quintanar
Default

Quote:
Originally Posted by BabyGT View Post
Check engine light come on? When's the last time you had or changed the oil yourself? Spark plugs ever been changed? Positive you have gas? Ever changed the fuel filter/air filter?
^^^^^^^
Natenqstang is offline   Reply With Quote
Old 04-11-2014, 01:31 PM   #5
BabyGT
5th Gear Member
 
BabyGT's Avatar
 
Join Date: Mar 2012
Vehicle: 2004 3.9 Vert & 1994 5.0 Vert
Location: Virginia
Posts: 2,038
X757XVeritas
Default

Quote:
Originally Posted by Natenqstang View Post
No check engine light. I changed the oil like 3 months ago.
Spark plugs have not been changed in almost 4 years. Damn.
I filled up the tank the day before. Fuel filter was changed last year.
"Like" 3 months, or at 3 months, cause that's pushing it. Have you checked it since you changed it? Go check it now.
__________________


04 3.9l Convertible- Daily driver
94 5.0l Convertible- Work in progress
92 5.0l Hatchback- Another work in progress
BabyGT is offline   Reply With Quote
Old 04-11-2014, 01:31 PM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Tags
fuel filter, gas, help me, misfire, transmission

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 01:11 PM.

© Internet Brands, Inc.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup