Running Amp Power cord - Page 3 - MustangForums.com



2005-2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-21-2007, 06:42 PM   #21  
tilt
2nd Gear Member
 
Join Date: Nov 2006
Posts: 293
Default RE: Running Amp Power cord

I ended up using the grommet in the wheel well. You have to remove the wheel and the platic fender pieces, but do that and it is easy to see and access. TechmanBD posted some pictures earlier in this thread that show what I am talking about.
tilt is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
First Mustang 99' 3 differnt body kits installed TimeLord101 New Member Area 3 09-04-2015 09:27 AM
03 V6 Mustang Ticking Noise Emblazoned General Tech 0 09-03-2015 10:45 PM
Help! Metra 70-5521 AMP Harness Install cbird1177711 2005-2014 Mustangs 2 09-03-2015 08:43 PM
2003 mach stereo has low volume iamgobono General Tech 0 09-03-2015 12:37 PM
Best Place To Run Power Wire/Firewall '08 cbird1177711 2005-2014 Mustangs 3 09-02-2015 08:51 PM


Tags
05, 2006, 2011, 89, amp, cable, color, cord, gt, install, mustang, power, run, running, stock, wire

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 08:52 AM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.