Boss Intake installed but...? - MustangForums.com



2005-2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 11-30-2011, 03:11 PM   #1
delusiondejavu
2nd Gear Member
Thread Starter
 
delusiondejavu's Avatar
 
Join Date: Nov 2011
Location: VA
Posts: 226
Default Boss Intake installed but...?

I had the Boss Intake installed along with Bama 93 tune at my local shop. When I started the car it made a few weird clunking/popping noises the idle changed a few times and then it was perfect. I drove it for 30 miles and it was perfect. So is that a normal thing to hear after this type of install? I only have 8K miles on my car and would prefer it not to become a paperweight
delusiondejavu is offline   Reply With Quote
Old 11-30-2011, 03:25 PM   #2
stags
3rd Gear Member
 
Join Date: May 2011
Location: California, Colorado
Posts: 695
Default

Did you tell Bama bout the intake?

And it was probably just a function of the computer adjusting itself
stags is offline   Reply With Quote
Old 11-30-2011, 03:36 PM   #3
delusiondejavu
2nd Gear Member
Thread Starter
 
delusiondejavu's Avatar
 
Join Date: Nov 2011
Location: VA
Posts: 226
Default

Quote:
Originally Posted by stags View Post
Did you tell Bama bout the intake?

And it was probably just a function of the computer adjusting itself
Yes I have the tune for the Boss intake and I was kinda thinking that it might be the computer learning but I assumed that the shop had started the car before.
delusiondejavu is offline   Reply With Quote
Old 11-30-2011, 03:48 PM   #4
onederful100
6th Gear Member
 
onederful100's Avatar
 
Join Date: Jul 2007
Location: Honolulu, HI
Posts: 6,128
Default

i would guess that it is the computer adjusting.

if it is working perfect, give it more time before you start looking for something wrong.
it may be working fine.

congrats on the Boss intake!
onederful100 is offline   Reply With Quote
Old 11-30-2011, 03:52 PM   #5
delusiondejavu
2nd Gear Member
Thread Starter
 
delusiondejavu's Avatar
 
Join Date: Nov 2011
Location: VA
Posts: 226
Default

Quote:
Originally Posted by onederful100 View Post
i would guess that it is the computer adjusting.

if it is working perfect, give it more time before you start looking for something wrong.
it may be working fine.

congrats on the Boss intake!
Thanks and I have a slightly negative outlook at times... Always expecting the worst case scenario....
delusiondejavu is offline   Reply With Quote
Old 11-30-2011, 03:59 PM   #6
delusiondejavu
2nd Gear Member
Thread Starter
 
delusiondejavu's Avatar
 
Join Date: Nov 2011
Location: VA
Posts: 226
Default

delusiondejavu is offline   Reply With Quote
Old 11-30-2011, 04:42 PM   #7
MELLOWYELLOW06
6th Gear Member
 
MELLOWYELLOW06's Avatar
 
Join Date: Oct 2006
Location: Los Angeles
Posts: 5,577
Default

I am assuming the car was adjusting itself to the new hardware and software updated. It let out a couple burps and all went well. I think you'll be fine and this is coming from another guy who looks at the worst case scenario.
MELLOWYELLOW06 is offline   Reply With Quote
Old 11-30-2011, 06:11 PM   #8
AMDanBailer
Platinum Sponsor
 
AMDanBailer's Avatar
 
Join Date: Oct 2009
Location: PA
Posts: 2,269
Default

Quote:
Originally Posted by delusiondejavu View Post
I had the Boss Intake installed along with Bama 93 tune at my local shop. When I started the car it made a few weird clunking/popping noises the idle changed a few times and then it was perfect. I drove it for 30 miles and it was perfect. So is that a normal thing to hear after this type of install? I only have 8K miles on my car and would prefer it not to become a paperweight
Quote:
Originally Posted by delusiondejavu View Post

Looks awesome, Brian! Thanks for posting!

As for the sounds you heard, without actually being there to check the install(which is very straightforward and pretty hard to mess up) I would say you should be just fine. As long as there was no CELs or really abnormal sounds that were/are persistent, I wouldn't worry. The only thing that I would look into is to scan the PCM for stored DTCs and to make sure there are no leaks after the MAF anywhere that would mess with/screw up the tune.

Beyond that, the car making some different noises is common with new parts/new tunes as significant as changing out the intake plenum and they should go away after driving it a short distance. Of course, if they do not and you have persistent abnormal noises, please don't hesitate to contact myself directly or the shop who installed everything for you.

I hope this helps! Enjoy the new manny/tune! Have a great night!
AMDanBailer is offline   Reply With Quote
Old 11-30-2011, 10:10 PM   #9
delusiondejavu
2nd Gear Member
Thread Starter
 
delusiondejavu's Avatar
 
Join Date: Nov 2011
Location: VA
Posts: 226
Default

I will update after I drive the car more but as of right now it seems all good...
delusiondejavu is offline   Reply With Quote
Old 12-01-2011, 05:09 PM   #10
AMDanBailer
Platinum Sponsor
 
AMDanBailer's Avatar
 
Join Date: Oct 2009
Location: PA
Posts: 2,269
Default

Quote:
Originally Posted by delusiondejavu View Post
I will update after I drive the car more but as of right now it seems all good...


Cool! Keep me updated, Brian! Have a great night!
AMDanBailer is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Did a few mods this summer... drfister 2005-2014 Mustangs 9 09-04-2015 07:47 AM
HP Gains Without Headers GimpyHSHS 4.6L (1996-2004 Modular) Mustang 7 08-29-2015 06:30 PM
Question regarding intake plenum for 5.4 DOHC swap Gary Ugarek 4.6L (1996-2004 Modular) Mustang 8 08-26-2015 08:41 AM
californiaspec [email protected] New Member Area 5 08-18-2015 09:01 PM
Need Help Diagnosing Have Codes (Confused) djbigskrilla 2005-2014 Mustangs 13 08-11-2015 12:59 PM


Tags
2011, 50, bama, boss, forum, gt, hard, install, installed, intake, leak, mustang, noise

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 08:35 PM.