2013-14 GT500 Exhaust--The Beast - MustangForums.com



2005-2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 11-18-2013, 09:48 AM   #1
tjhinker
Thread Starter
 
Join Date: Sep 2013
Location: Michigan
Posts: 7
Default 2013-14 GT500 Exhaust--The Beast

tjhinker is offline   Reply With Quote
Old 11-18-2013, 10:06 AM   #2
Rudolph Hucker
4th Gear Member
 
Rudolph Hucker's Avatar
 
Join Date: Oct 2012
Location: sweden
Posts: 1,139
Default

sounds fekin awesome
Rudolph Hucker is offline   Reply With Quote
Old 11-19-2013, 11:26 AM   #3
808muscle
5th Gear Member
 
808muscle's Avatar
 
Join Date: Oct 2009
Location: Maui
Posts: 4,752
Default

That's a winner
808muscle is offline   Reply With Quote
Old 11-20-2013, 06:41 AM   #4
tjhinker
Thread Starter
 
Join Date: Sep 2013
Location: Michigan
Posts: 7
Default

Quote:
Originally Posted by 808muscle View Post
That's a winner
tjhinker is offline   Reply With Quote
Old 11-20-2013, 09:02 AM   #5
Matt's 95 Stang
Resident Ginger
 
Matt's 95 Stang's Avatar
 
Join Date: Nov 2006
Location: Cali
Posts: 4,623
Default

Matt's 95 Stang is offline   Reply With Quote
Old 11-20-2013, 12:01 PM   #6
tjhinker
Thread Starter
 
Join Date: Sep 2013
Location: Michigan
Posts: 7
Default

LMAO!
tjhinker is offline   Reply With Quote
Old 11-21-2013, 01:50 PM   #7
Tberg725
3rd Gear Member
 
Tberg725's Avatar
 
Join Date: Jul 2006
Location: Michigan
Posts: 828
Default

Sounds good, only thing I dislike is the tips
Tberg725 is offline   Reply With Quote
Old 01-09-2014, 02:31 PM   #8
tjhinker
Thread Starter
 
Join Date: Sep 2013
Location: Michigan
Posts: 7
Default

Beveled edge tips are beautiful IMO
tjhinker is offline   Reply With Quote
Old 01-09-2014, 02:45 PM   #9
Andy13186
4th Gear Member
 
Andy13186's Avatar
 
Join Date: Apr 2008
Posts: 1,781
Default

guy needed to give it some full throttle, that was like 5 basically idling passes
Andy13186 is offline   Reply With Quote
Old 01-10-2014, 06:43 AM   #10
tjhinker
Thread Starter
 
Join Date: Sep 2013
Location: Michigan
Posts: 7
Default

It was cold. Tires wouldnt hook up
tjhinker is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
S197 Parts baddog671 Parts For Sale 20 07-26-2016 01:20 PM
Terminated Whipple GT battles '13 GT500 on E85 Bokeo Street/Strip 6 10-10-2015 08:28 PM
GT500 front LCA question UrS4 S197 Handling Section 1 09-30-2015 10:13 AM
Paint & Body People! I have a question! GLOCKer General Tech 0 09-28-2015 07:36 AM
Corsa GT500 Sport Quad Tip on a 13 GT/CS FivePointToTheOh 2005-2014 Mustangs 2 09-21-2015 01:21 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 05:46 PM.