Not happy with my car right now - MustangForums.com



2005-2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 07-08-2014, 11:02 AM   #1
yourmyboybh1026
3rd Gear Member
Thread Starter
 
yourmyboybh1026's Avatar
 
Join Date: Apr 2009
Location: Clearwater FL
Posts: 598
Default Not happy with my car right now

So, I've been having a lot of problems with my car recently, AC won't work, radio goes in and out, temp gauge doesn't work, and I can't fill the car up because it just spits the gas back at me. I took the car to a dealership to have them look at it and this is what I'm told:

They can't fix the radio because its aftermarket and they don't know what was done to it (the radio worked for 3 years prior to this), the AC has no leaks or anything like that but the compressor isn't being told to turn on, so the PCM is faulty, and that the EVAP device by the gas tank is broke so I have to replace it. That will cost $800. How does that just all of a sudden decide to not work?

Sigh, I think I'm going to end up selling this hunk of crap unless I can find some way to fix these issues. Any ideas?
yourmyboybh1026 is offline   Reply With Quote
Old 07-08-2014, 11:42 AM   #2
gmoran1469
3rd Gear Member
 
Join Date: Jan 2010
Location: Louisiana
Posts: 738
Default

Quote:
Originally Posted by yourmyboybh1026 View Post
So, I've been having a lot of problems with my car recently, AC won't work, radio goes in and out, temp gauge doesn't work, and I can't fill the car up because it just spits the gas back at me. I took the car to a dealership to have them look at it and this is what I'm told:

They can't fix the radio because its aftermarket and they don't know what was done to it (the radio worked for 3 years prior to this), the AC has no leaks or anything like that but the compressor isn't being told to turn on, so the PCM is faulty, and that the EVAP device by the gas tank is broke so I have to replace it. That will cost $800. How does that just all of a sudden decide to not work?

Sigh, I think I'm going to end up selling this hunk of crap unless I can find some way to fix these issues. Any ideas?
If the radio is modified it's not fords fault it doesn't work anymore. Also, it's a 5 year old car, **** breaks and need replacing. It happens. You are gonna lose more money selling the car and buying another than you will fixing the issues you have.
gmoran1469 is offline   Reply With Quote
Old 07-08-2014, 11:52 AM   #3
yourmyboybh1026
3rd Gear Member
Thread Starter
 
yourmyboybh1026's Avatar
 
Join Date: Apr 2009
Location: Clearwater FL
Posts: 598
Default

Quote:
Originally Posted by gmoran1469 View Post
If the radio is modified it's not fords fault it doesn't work anymore. Also, it's a 5 year old car, **** breaks and need replacing. It happens. You are gonna lose more money selling the car and buying another than you will fixing the issues you have.
I understand its not Ford's fault for the radio, I just didn't understand how that EVAP system just all of a sudden stops working. I know I'd lose money, which is why i don't want to sell it, but its VERY frustrating owning this car right now. Plus I have no clue if I would lose more money than it would cost because I can't find anywhere that can figure out the problem so they can't really fix it. I took it to 2 shops before the dealership.

Does anyone know of any good performance shops near OKC. Thats where I'm moving to in about a week. Maybe if I can find someone used to installing aftermarket parts they can figure it out.
yourmyboybh1026 is offline   Reply With Quote
Old 07-08-2014, 11:59 AM   #4
Roy_R
4th Gear Member
 
Roy_R's Avatar
 
Join Date: Apr 2008
Location: San Diego, CA
Posts: 1,483
Default

Google a bit, and you'll figure stuff out....don't be afraid to get your hands dirty if you want to save money!

http://forums.themustangsource.com/f...lution-465217/

There are also online manuals for these cars...
Roy_R is offline   Reply With Quote
Old 07-08-2014, 12:08 PM   #5
808muscle
5th Gear Member
 
808muscle's Avatar
 
Join Date: Oct 2009
Location: Maui
Posts: 4,752
Default

Weird stuff happens when you get the dreaded water leak. Water into the cabin by the smart junction box passenger side. Check for that. The fuel issue. My car has had it since I got it and my 2011 ford cube van has since day 1. Ford managed to design a total pos setup. It's so frustrating.
808muscle is offline   Reply With Quote
Old 07-08-2014, 12:21 PM   #6
yourmyboybh1026
3rd Gear Member
Thread Starter
 
yourmyboybh1026's Avatar
 
Join Date: Apr 2009
Location: Clearwater FL
Posts: 598
Default

Quote:
Originally Posted by Roy_R View Post
Google a bit, and you'll figure stuff out....don't be afraid to get your hands dirty if you want to save money!

http://forums.themustangsource.com/f...lution-465217/

There are also online manuals for these cars...
For the last 2 months I've been googling, posting here, asking friends, everything. No one can seem to find the issue and so its over my level of expertise. I guess I can do the EVAP thing myself, but that is honestly the least of my problems. I need to get the AC, radio, temp gauge and cylinder head temp sensor fixed.

Quote:
Weird stuff happens when you get the dreaded water leak. Water into the cabin by the smart junction box passenger side. Check for that. The fuel issue. My car has had it since I got it and my 2011 ford cube van has since day 1. Ford managed to design a total pos setup. It's so frustrating.
I have checked several times for the water leak, basically any time it rains here and never found anything.
yourmyboybh1026 is offline   Reply With Quote
Old 07-08-2014, 02:34 PM   #7
dlazrael
5th Gear Member
 
dlazrael's Avatar
 
Join Date: May 2005
Location: Maryland
Posts: 2,111
Default

As for EVAP stuff just happens, I had an 08 Impala that the EVAP canister just rusted out at the connector... No idea why, it wasn't exposed to ANYTHING, it was behind the splash guard and everything. Once I swapped it out (about a 30 minute job) everything was fine.

These cars are pretty decent (generally). Though as they age they break.. it happens.

Also, check with the tuners, MAYBE something in the tune affected the AC. The AC is a complex system now-a-days... You could try reverting to stock and seeing if it works without the tune. If it does, then its the tune, if not, then its something else.... Just a thought
dlazrael is offline   Reply With Quote
Old 07-08-2014, 02:54 PM   #8
SPARTAN VI
4th Gear Member
 
SPARTAN VI's Avatar
 
Join Date: Sep 2005
Location: Los Angeles, California
Posts: 1,926
Default

$800 is a drop in the bucket compared to the amount of cash you'd hemorrhage on a new car. Either way, I'd look into DIY'ing as much of this as possible, then get everything else done by a non-dealership mechanic (IME, they charge too much).
SPARTAN VI is offline   Reply With Quote
Old 07-08-2014, 05:33 PM   #9
outceltj
4th Gear Member
 
outceltj's Avatar
 
Join Date: Sep 2010
Location: IN
Posts: 1,984
Default

Alternator???? maybe battery
outceltj is offline   Reply With Quote
Old 07-08-2014, 06:35 PM   #10
P51V6
 
Join Date: Jul 2014
Location: NEW YORK
Posts: 22
Default

Sadly I've been having a lot of little problems like this and mine is a 13 with 12k miles. I love my car but there's no way i'm keeping it when the warranty runs out. I hope you figure things out.
P51V6 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Looking at a "nearly new" '06 GT Luclin999 2005-2014 Mustangs 19 09-07-2015 11:33 PM
Visual mods complete bluebeastsrt The New S550 2015-2017 Mustang 4 08-22-2015 07:29 PM
New Silver '15 V6! jink21 Members Rides and Car Show Section 3 08-13-2015 04:33 PM
Groaning noise coming from rear when turning right 92 5.0stang 5.0L (1979-1995) Mustang 4 08-13-2015 06:46 AM
FORD FRENZY!!! Milan Dragway-September 12th Milan Dragway Members Rides and Car Show Section 0 08-12-2015 03:43 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 09:27 AM.