2005 4.0L Not Blowing Hot Air - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > 2005-2014 Mustangs
Reload this Page >

2005 4.0L Not Blowing Hot Air

Notices
2005-2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.

2005 4.0L Not Blowing Hot Air

Reply

 
 
 
Old 12-13-2017, 01:44 PM
  #1  
cpelkey
Thread Starter
 
Join Date: Dec 2017
Location: NB
Posts: 4
Default 2005 4.0L Not Blowing Hot Air

So I had a pretty bad coolant leak due to a cracked thermostat housing. I replaced the thermostat housing and thermostat only to find that there was still a slight leak. I replaced the thermostat sensor as the o-ring on it was in rough shape and the sensor itself looked like it had seen better days. I flushed the entire system of coolant and refilled it. When I turned the car back on, the air coming out of the vents started to warm up along with the engine, seemed great. I fixed the car in my father's garage, on my way home the car started blowing cold air even though the gauge was showing that the engine was warm. Could this just be the result of a faulty thermostat in the part that I ordered? Or an issue with the fact that I flushed and refilled the car?
cpelkey is offline  
Reply With Quote
Old 12-13-2017, 05:59 PM
  #2  
JimC
Moderator
 
JimC's Avatar
 
Join Date: May 2006
Location: North Carolina
Posts: 7,144
Default

You probably have an air pocket trapped in the system from the flush and refill. How did you do the refill process?
JimC is offline  
Reply With Quote
Old 12-13-2017, 06:08 PM
  #3  
cpelkey
Thread Starter
 
Join Date: Dec 2017
Location: NB
Posts: 4
Default

Hey Jim,

I drained the fluid from the spigot in the bottom of the radiator, put the plug back in and then filled it up. At one point after refilling the car, however, I did take the thermostat housing off again as I thought that it may have been improperly seated (turned out the leak was from around the sensor not the bottom of the housing). I reinstalled the housing and then topped my car up.

How would I get rid of a bubble if there was one?
cpelkey is offline  
Reply With Quote
Old 12-13-2017, 06:11 PM
  #4  
cpelkey
Thread Starter
 
Join Date: Dec 2017
Location: NB
Posts: 4
Default

Oh nevermind, I found a good youtube video. Thanks for the help, I'll let you know if it worked!
cpelkey is offline  
Reply With Quote
Old 12-13-2017, 06:59 PM
  #5  
cpelkey
Thread Starter
 
Join Date: Dec 2017
Location: NB
Posts: 4
Default

That did the trick, thanks!
cpelkey is offline  
Reply With Quote
Old 12-13-2017, 09:00 PM
  #6  
JimC
Moderator
 
JimC's Avatar
 
Join Date: May 2006
Location: North Carolina
Posts: 7,144
Default

Originally Posted by cpelkey View Post
That did the trick, thanks!
You're welcome. Glad to hear it was something simple
JimC is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
SANDY21
V6 (1994-2004) Mustangs
3
08-17-2015 02:41 PM
1999 GT
4.6L (1996-2004 Modular) Mustang
21
06-12-2008 04:27 PM
003trublugt315
4.6L (1996-2004 Modular) Mustang
17
04-01-2008 11:32 AM
washingtonkevin
V6 (1994-2004) Mustangs
8
03-09-2007 01:24 PM
tron2003
4.6L (1996-2004 Modular) Mustang
15
02-13-2006 06:02 PM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory