Notices
2005-2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.

Blower motor issues after car wash

Old 03-06-2019, 09:29 AM
  #1  
Lee9998
Thread Starter
 
Join Date: Mar 2019
Location: Minnesota
Posts: 4
Default Blower motor issues after car wash

So this has happened a couple times now. I drive a 2013 mustang V6. Every time I go through the car wash my blower motor makes a weird hissing sound almost like static on the radio (loud) and the air coming out of the vents is almost nothing. I live in MN and it is around 20 degrees however the car gets parked in the garage. The windows also tend to fog. Several min of driving later the sound disappears and the blower motor seems to operate normally. Anyone have an idea what’s going on?
Lee9998 is offline  
Old 03-06-2019, 11:43 AM
  #2  
Dino Dino Bambino
3rd Gear Member
 
Dino Dino Bambino's Avatar
 
Join Date: Oct 2014
Location: Cyprus (EU)
Posts: 854
Default

Check if the cowl drains are blocked. If there's water accumulated in the cowl, it may be making its way into the front passenger side footwell via the cabin air filter and contaminating the smart junction box. This can cause funky electrical issues like the ones you've described.
Dino Dino Bambino is online now  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Daytripper540
Off Topic
21
08-15-2011 04:31 PM
5pointslow91
4.6L (1996-2004 Modular) Mustang
11
10-08-2010 12:01 AM
evilcw311
5.0L (1979-1995) Mustang
13
03-24-2010 08:06 PM
2k-convert-gt
4.6L (1996-2004 Modular) Mustang
11
06-25-2009 11:11 PM


Thread Tools
Search this Thread
Quick Reply: Blower motor issues after car wash


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.