MT-82 transmission issue - MustangForums.com



3.7L V6 Technical Discussions Any questions about the new engine, transmission, exhaust, tuners/CAI, or gearing can be asked here!

Reply
 
 
 
Thread Tools Search this Thread
Old 05-21-2018, 08:32 PM   #1  
3pointSeven
Thread Starter
 
3pointSeven's Avatar
 
Join Date: May 2018
Location: KY
Posts: 1
Default MT-82 transmission issue


Hello All!

its my first time posting and Iím hoping someone has an answer. I have a 2014 Mustang V6 Performance Package with the MT-82 manual transmission. Here in the last couple of days with prolonged driving (over 20 min). My shifts are becoming ďstuckĒ and itís not going into neutral when needed. For example Iíll post a video of where when it should be in neutral and I left off the clutch, it then ďpopsĒ into neutral.

*Heres the kicker. I let my car sit for a couple hours and the issues completely goes away. No stuck shifts etc. shifting is smooth again. I actually got to Ford today with the issue so they could look at it and got an appt. however, the tech said heíll have to look more at it because he hasnít seen this exact issue. Iím attaching a clip I recorded. (Ignore my dad saying to get an automatic lol he grew up with manual transmissions and like the autos). Im
hoping someone can help or has had a similar issue.
3pointSeven is offline   Reply With Quote
Old 05-22-2018, 08:36 PM   #2  
Buck Sergeant
2nd Gear Member
 
Join Date: Aug 2017
Location: North Carolina
Posts: 399
Default MT-82 transmission issue

3pointSeven, check out this web-site. Pretty good information concerning your tranny, with possible solutions. https://www.cjponyparts.com/resource...n-your-mustang
Buck Sergeant is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Issue with my ride, vacum issue or fuel issue? uberstang1 4.6L (1996-2004 Modular) Mustang 0 07-05-2011 05:53 AM
Dashlight issue/Speedometer Issue 91 GT mustangdannyjr 5.0L (1979-1995) Mustang 4 02-16-2010 09:28 PM
Temp Guage issue, and Overheating issue Night Terror 5.0L (1979-1995) Mustang 9 10-01-2008 12:55 PM
(issue resolved)Need insight on 4.0L sohc cold morning hard start issue( no codes) squad272 General Tech 4 12-17-2007 07:09 PM
Fuel issue? Ignition issue? ARGH! Drexl 5.0L (1979-1995) Mustang 7 03-29-2007 09:17 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 05:56 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.