speedo broke? help plz - MustangForums.com

4.6L (1996-2004 Modular) Mustang Technical discussions on 1996-2004 4.6 Liter Modular Motors (2V and 4V) within.

speedo broke? help plz

Reply

 
 
 
Old 07-22-2007, 01:47 PM
  #1  
bikeboy587
4th Gear Member
Thread Starter
 
Join Date: Mar 2007
Location: Buffalo, NY
Posts: 1,541
Default speedo broke? help plz

I was drivin the other day and my speedometer just dropped from 60-0 and stopped working out of no where. Then I through a Check Engine light that was P 0500 - Vehicle speed sense malfunction. I thought I just broke a speedo gear or the cable but then a through that code. Since my car is a 96 I have the manual odometer adn speedo so I didn't think it was a conputer problem. Idk if i'm throwing that code just bec my car sees that my speedo ain't working or if I did have a sense fail. What do i need to fix??[/align]Thanks[/align]
bikeboy587 is offline  
Reply With Quote
Old 07-22-2007, 11:19 PM
  #2  
Colorado_Mustang
5th Gear Member
 
Join Date: Jun 2006
Location:
Posts: 4,089
Default RE: speedo broke? help plz

Check your post in the General section...I'm not retyping..
Colorado_Mustang is offline  
Reply With Quote
Old 07-23-2007, 03:22 PM
  #3  
Z28addiction
 
Join Date: Jul 2007
Location:
Posts: 5
Default RE: speedo broke? help plz

Dude just come over or ill come to your house and well run through the whole thing. well find the problem
Z28addiction is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
CMcNam
4.6L V8 Technical Discussions
15
12-06-2015 01:28 PM
stangin1996gt
4.6L (1996-2004 Modular) Mustang
0
09-21-2015 11:01 AM
cbird1177711
2005-2014 Mustangs
0
09-02-2015 04:12 PM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory