changed my injectors and running like ****t - Page 3 - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > 4.6L (1996-2004 Modular) Mustang
Reload this Page >

changed my injectors and running like ****t

4.6L (1996-2004 Modular) Mustang Technical discussions on 1996-2004 4.6 Liter Modular Motors (2V and 4V) within.

changed my injectors and running like ****t

Reply

 
 
 
Old 11-09-2007, 01:29 PM
  #21  
Dsmfighter
3rd Gear Member
 
Join Date: Jan 2005
Location: Canton Ohio
Posts: 731
Default RE: changed my injectors and running like ****t

ORIGINAL: 2002GTAUTOVERT

lmao.. the spray of a cobra injector is completely different than that on a GT (from what ive heard) put your stockers back in.
That would do it...I was just starting to think about that last night. Are they the same impedance as well?? I know on som cars it is important to make sure you have your injectors in at the proper angle ect.These are new injectors right? If not do a flow test if you can get the proper tools.
Dsmfighter is offline  
Reply With Quote
Old 11-09-2007, 01:39 PM
  #22  
mustang02racing
2nd Gear Member
 
Join Date: Mar 2006
Location:
Posts: 232
Default RE: changed my injectors and running like ****t

yes well i knew that if i changed my injectors i would need a tune so i did it just to see how the car reacts to the bigger injectors and its crazy............the car stalls, need to rev 1,000rpm to idle w/o stalling.....extremly rich...(smell the extra gas outside of the car...like 8mpg...lol...and totally not worth it with out a tune..............oh by the way the stock ones should be 19lb, thats what the 99-04 gts got on them....
mustang02racing is offline  
Reply With Quote
Old 11-09-2007, 11:04 PM
  #23  
g3tsum96gt
Thread Starter
 
Join Date: Oct 2007
Location:
Posts: 20
Default RE: changed my injectors and running like ****t

ok people, just got it fixed.... turns out its a bad injector.... changed it out and now its running like a champ... thanks for all the help FOR REAL THANKS
g3tsum96gt is offline  
Reply With Quote
Old 11-10-2007, 12:10 AM
  #24  
2000GT4.6
6th Gear Member
 
Join Date: Jan 2004
Location: United States
Posts: 12,575
Default RE: changed my injectors and running like ****t

ORIGINAL: g3tsum96gt

ok people, just got it fixed.... turns out its a bad injector.... changed it out and now its running like a champ... thanks for all the help FOR REAL THANKS
Without a custom tune its still going to run like ****, and you should still not be using cobra injectors as the spray pattern is completely different.

Almost zero chance you can just pi swap and then toss in some 24s and a MAF and call it a day without a retune.
2000GT4.6 is offline  
Reply With Quote
Old 11-10-2007, 12:33 PM
  #25  
Dsmfighter
3rd Gear Member
 
Join Date: Jan 2005
Location: Canton Ohio
Posts: 731
Default RE: changed my injectors and running like ****t

ORIGINAL: g3tsum96gt

ok people, just got it fixed.... turns out its a bad injector.... changed it out and now its running like a champ... thanks for all the help FOR REAL THANKS
Called it!!!!!!!! WOOT WOOT! [sm=happy046.gif]
Dsmfighter is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
drfister
2005-2014 Mustangs
11
05-03-2018 10:38 PM
adamfrosceno
New Member Area
2
08-27-2015 07:40 AM
mstahoo
SVT Forums
9
08-16-2015 09:12 AM
djbigskrilla
2005-2014 Mustangs
13
08-11-2015 12:59 PM
dfw692
5.0L (1979-1995) Mustang
4
08-07-2015 11:53 PM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory