Spark plugs!! - MustangForums.com


4.6L (1996-2004 Modular) Mustang Technical discussions on 1996-2004 4.6 Liter Modular Motors (2V and 4V) within.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-07-2003, 10:52 PM   #1  
Black Horse
3rd Gear Member
Thread Starter
 
Join Date: Sep 2003
Location: United States
Posts: 751
Default Spark plugs!!

Its that time for new plugs...Anyone have suggestions on brands, or should I just go with stock Ford plugs?
Black Horse is offline   Reply With Quote
Old 11-08-2003, 07:36 PM   #2  
vfast
I ♥ Acer
 
Join Date: Jul 2003
Location:
Posts: 11,394
Default Spark plugs!!

ngk's are good a lil expensive..I use either mortorcraft or autolite..in my car I can't use boush or the like..maybe the 2 prong split fires
vfast is offline   Reply With Quote
Old 11-09-2003, 09:39 PM   #3  
w11988
1st Gear Member
 
Join Date: Sep 2003
Location:
Posts: 138
Default Spark plugs!!



I just put in the standard Motocraft plugs today. I'll let you know if I have a problem. My car wasn't really running bad, it was just 60k miles and I figured it was time. Plus I would rather spend a couple hours on Sunday with the Stang that a couple hours watching the tube. <IMG src=smileys/smiley1.gif border="0"></P>


I would recommend being careful when buying the plugs. I went to AutoZone, and it definitely makes a difference between 3.8l and 4.6l plugs. I was almost given the 3.8l plugs which are definitely a different part.</P>
w11988 is offline   Reply With Quote
Old 11-11-2003, 04:15 AM   #4  
1967stang
 
Join Date: Jun 2003
Location: United States
Posts: 30
Default Spark plugs!!



<FONT size=4>DENSO URIDIUM </FONT></P>


<FONT size=2>all the way. there expensive like 15 bucks a pop but they rock. For some reason to me they just burn right.</FONT></P>


<FONT size=2>do not get those peice of **** boosch platium 4 plugs or whatever the hell there called. they suck donkey di#k.</FONT></P>
1967stang is offline   Reply With Quote
Old 11-11-2003, 11:07 AM   #5  
vfast
I ♥ Acer
 
Join Date: Jul 2003
Location:
Posts: 11,394
Default Spark plugs!!

the 4 prong work you can't use a stock igition.. 100.00 for plugs is crazy...you would better if you bought autolites for 10.00 and a hipo coil 50.00 and a set of low ohm plug wires 50.00
vfast is offline   Reply With Quote
Old 11-11-2003, 11:30 AM   #6  
jerr3d
 
Join Date: Nov 2003
Location: United States
Posts: 19
Default Spark plugs!!

Pardon my newbeeNess, that's why I am here.

My dealer told me my GT has 100,000 miles plugs in it.

What's up wid dat?
jerr3d is offline   Reply With Quote
Old 11-11-2003, 01:16 PM   #7  
Snydaleid
2nd Gear Member
 
Join Date: Aug 2003
Location:
Posts: 212
Default Spark plugs!!



Quote:
Originally Posted by 1967stang
<FONT size=2>do not get those peice of **** boosch platium 4 plugs or whatever the hell there called. they suck donkey di#k.</FONT>
</P>


I agree. Don't waste your money on splitfires either. </P>
Snydaleid is offline   Reply With Quote
Old 11-11-2003, 02:51 PM   #8  
Monch
3rd Gear Member
 
Join Date: Sep 2003
Location: United States
Posts: 606
Default Spark plugs!!



the ignition system on late model mustangs is pretty good. just get a decent set of regular platinum tipped plugs - ngk or bosch. iridums will get you a MAX of 1 hp over the stock setup - you'd never even notice it, you would notice the missing $100.</P>


</P>
Monch is offline   Reply With Quote
Old 11-11-2003, 07:48 PM   #9  
Black Horse
3rd Gear Member
Thread Starter
 
Join Date: Sep 2003
Location: United States
Posts: 751
Default Spark plugs!!



Quote:
Originally Posted by vfast
the 4 prong work you can't use a stock igition.. 100.00 for plugs is crazy...you would better if you bought autolites for 10.00 and a hipo coil 50.00 and a set of low ohm plug wires 50.00
</P>


Hey vfast, mines a 2001... it has coil on plugs with no wires....just to let ya know.. <IMG src=smileys/smiley2.gif border="0"></P>
Black Horse is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
what are the odds - Service Engine Soon light lincolnshibuya V6 (1994-2004) Mustangs 9 12-08-2015 04:37 PM
Bad cylinder? Dathan V6 (1994-2004) Mustangs 4 10-05-2015 05:52 AM
04 Mach 460 system, Installed Aftermarket HU, No Highs/Tweeters breaking Audio/Visual Electronics 5 10-02-2015 01:27 PM
Clear codes on '94 sn95 BOB ROME 5.0L (1979-1995) Mustang 2 09-28-2015 11:10 AM
Slight surge at 1500ish rpm lmurf60 4.6L (1996-2004 Modular) Mustang 1 09-24-2015 10:07 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 03:15 AM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.