NEED HELP WITH MY 02 GT!!! PLEASE - Page 2 - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > 4.6L (1996-2004 Modular) Mustang
Reload this Page >

NEED HELP WITH MY 02 GT!!! PLEASE

Notices
4.6L (1996-2004 Modular) Mustang Technical discussions on 1996-2004 4.6 Liter Modular Motors (2V and 4V) within.

NEED HELP WITH MY 02 GT!!! PLEASE

Reply

 
 
 
Old 11-25-2009, 05:36 PM
  #11  
02GTpit
Thread Starter
 
Join Date: Nov 2009
Location: oklahoma
Posts: 10
Default

yeah it didnt move at all!! what do you think it is when it was parked 2 years ago it ran like a champ
02GTpit is offline  
Reply With Quote
Old 11-25-2009, 06:59 PM
  #12  
JC316
4th Gear Member
 
JC316's Avatar
 
Join Date: May 2009
Location: DFW, TX
Posts: 1,925
Default

Originally Posted by 02GTpit View Post
yeah it didnt move at all!! what do you think it is when it was parked 2 years ago it ran like a champ
Since it's not smoking, I would rule out a hole in the piston. Did it ever knock? Maybe the rod bolts somehow worked their way loose, thus disconnecting the piston from the crankshaft.... Any way you look at it, you are going to be doing major engine repair. I would go so far as saying that you may need a whole new motor.
JC316 is offline  
Reply With Quote
Old 11-26-2009, 12:02 AM
  #13  
02GTpit
Thread Starter
 
Join Date: Nov 2009
Location: oklahoma
Posts: 10
Default

no its never knocked or tap and id dont make any funny sounds and it still runs pretty good like im pretty sure it will hang with my brothers 96 cobra he just wont race me
02GTpit is offline  
Reply With Quote

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.