My fog lamps are not working on my recently bought 2004 gt, help please! - MustangForums.com


4.6L General Discussion This section is for non-tech specific information pertaining to 4.6L (Modular) Mustangs built from 1996 to 2004.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-13-2011, 06:26 PM   #1  
dominant1
3rd Gear Member
Thread Starter
 
dominant1's Avatar
 
Join Date: Jul 2009
Location: Delaware
Posts: 659
Default My fog lamps are not working on my recently bought 2004 gt, help please!

Hey guys when i turn my regular lights on, then click the button for my fog lamps, i get no light. The button led lights up. Is this a fuse situation or a bulb situation or a complete replacement issue? any insight would be a great help, thanks.....
dominant1 is offline   Reply With Quote
Old 07-13-2011, 08:47 PM   #2  
trailor
3rd Gear Member
 
trailor's Avatar
 
Join Date: Mar 2009
Location: NOLA
Posts: 665
Default

start with the easiest first. check the fuse to see if its busted. then inspect the light bulbs in the fogs. if those are both fine, get back on here and let us know. when i first got my stang, one bulb was burnt out and the other was crushed, so you never know.
trailor is offline   Reply With Quote
Old 07-13-2011, 09:46 PM   #3  
SyNdicateZ
3rd Gear Member
 
SyNdicateZ's Avatar
 
Join Date: Feb 2011
Location: Mass
Posts: 988
Default

ya, First check fuse, if its not that then check the bulbs and and replace... If that dont help something is wrong with the wiring..?
SyNdicateZ is offline   Reply With Quote
Old 07-13-2011, 09:48 PM   #4  
dominant1
3rd Gear Member
Thread Starter
 
dominant1's Avatar
 
Join Date: Jul 2009
Location: Delaware
Posts: 659
Default

ok thanks
dominant1 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
97 Convertible Power Top Wiring Diagram importsmasher V6 (1994-2004) Mustangs 4 10-09-2015 04:42 PM
700hp 4.75l am i on the right track 2003 4.75l 4.6L (1996-2004 Modular) Mustang 14 08-29-2015 02:58 AM
700hp 4.75l am i on the right track 2003 4.75l 4.6L (1996-2004 Modular) Mustang 0 08-18-2015 10:35 PM
02 wrx BlueBells96 Off Topic 18 08-14-2015 10:57 PM
2004 v6 Rumble/Shake on startup Itstbrown V6 (1994-2004) Mustangs 1 08-09-2015 03:49 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 06:37 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.