New to MF - MustangForums.com



4.6L General Discussion This section is for non-tech specific information pertaining to 4.6L (Modular) Mustangs built from 1996 to 2004.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-09-2013, 09:57 AM   #1
carlvolk
Thread Starter
 
Join Date: Oct 2013
Location: Georgia
Posts: 1
Default New to MF

two questions, please.
1999 GT 4.6L low coolant level light stays on even when tank is full. Sensor appears to be built into bottom corner of tank. Any known issues here?

Never had to change a tire and therefore do not know location of jack points. Car had ground effects. Anyone have a picture?

thanks
(I am new to this posting "stuff" so forgive me if I did not follow proper protocol-I will learn)
carlvolk is offline   Reply With Quote
Old 10-12-2013, 07:46 PM   #2
0331
1st Gear Member
 
0331's Avatar
 
Join Date: Sep 2013
Location: NC
Posts: 53
Default

Quote:
Originally Posted by carlvolk View Post

Never had to change a tire and therefore do not know location of jack points. Car had ground effects. Anyone have a picture?
http://www.americanmuscle.com/99-04-...-install1.html

The first picture in the link provides the jack points. I would have directly inserted the picture but the server I am on blocks media sharing and picture hosting sites.

You might have a bad sensor, but I don't know of any problems with them.
0331 is offline   Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 05:28 AM.