Notices
4.6L General Discussion This section is for non-tech specific information pertaining to 4.6L (Modular) Mustangs built from 1996 to 2004.

High temp. High oil pressure.

Old 03-21-2019, 06:15 PM
  #1  
Skidball
Thread Starter
 
Join Date: Mar 2018
Location: Mi.
Posts: 37
Default High temp. High oil pressure.

Anyone have this problem or any suggestions ? The car sat for a long time. Got it running again. Compression test was ok. Changed a lot of stuff on car. Radiator was leaking . So changed that, and hoses, thermostat , water pump , and radiator cap. Changed oil . Motorcraft 820s filter, and used advanced auto brand oil 5-30 . Cars runs great and starts great. Have heat . Works good. Everything runs normal , then after 10 minutes the temp and oil gauge peg out . Someone mentioned to check actual temp and oil pressure. Not sure how to go about that ? Is it something to do with my oil ? Should I change my oil again ?
Skidball is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
millerwilliampeter
Classic Mustangs (Tech)
1
02-22-2010 06:48 PM
Kielian15
Audio/Visual Electronics
0
11-14-2008 08:49 PM
dawssvt
Parts For Sale
2
12-29-2007 06:03 AM
mustang v6
2005-2014 Mustangs
1
10-13-2006 08:52 PM
Toddman0025
Classic Mustangs (Tech)
10
08-13-2006 10:07 PM


Thread Tools
Search this Thread
Quick Reply: High temp. High oil pressure.


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.