Really scary throttle issue, Bullitt tuning or something wrong here. - MustangForums.com



4.6L V8 Technical Discussions Any questions about engine, transmission, or gearing can be asked here!
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 09-20-2015, 09:16 PM   #1
JDWalton
5th Gear Member
Thread Starter
 
JDWalton's Avatar
 
Join Date: Apr 2007
Location: CT
Posts: 2,612
Exclamation Really scary throttle issue, Bullitt tuning or something wrong here.

Hey Guys. Here is the current mod list:

2008 Mustang GT Bullitt
Ford Racing Intake (Factory)
Ford Racing dual 62mm throttle body
Ford Racing Intake Manifold
Steff's Catch Can
Brenspeed Detroit Rocker Force Induction grind cams
BBK Shorty Headers
Cat deleted on Bullitt H pipe
GT500 type mufflers
Accel Coils
Fresh plugs, gapped to 32

Here is the problem:
Many times if I step hard on the throttle it feels like I am pulling a boat for a few seconds then goes. Or if I get off and stab it again it will snap to it.

Sometimes when I accelerate hard, like full pull through second gear from 2k to about 5500 RPM, and shift to neutral, or like if you had to jam onto the break cause your trying not to have a an "oh god oh god were all gonna die moment,' sometimes the throttle just runs away.

American muscle email tune, they are looking on their end, I want to see about anything it can be on my end.

Any ideas?

Last edited by JDWalton; 09-20-2015 at 09:23 PM.
JDWalton is offline   Reply With Quote
Old 09-20-2015, 10:29 PM   #2
algregory
3rd Gear Member
 
Join Date: Jan 2005
Location: New Bern, NC
Posts: 650
Default

I have an '05 GT and maybe it is totally from left field. But there was a thing about "training" your throttle with the ignition on and the engine off. Something about if you drove your car "easy peasy" that your throttle would "train" for that. I know that I used to "train" my throttle on occasion, and I felt there was a difference after I did it.
algregory is offline   Reply With Quote
Old 09-21-2015, 04:19 AM   #3
JDWalton
5th Gear Member
Thread Starter
 
JDWalton's Avatar
 
Join Date: Apr 2007
Location: CT
Posts: 2,612
Default

thanks. I did try that throttle thing once, no help. bunch of ignition cycles or something then a series of throttle sweeps right?
JDWalton is offline   Reply With Quote
Old 09-21-2015, 09:38 AM   #4
jpplaw
3rd Gear Member
 
jpplaw's Avatar
 
Join Date: Jun 2010
Location: RI
Posts: 690
Default

Its a tune problem....cams can be a pain to tune for
jpplaw is offline   Reply With Quote
Old 09-22-2015, 06:10 AM   #5
JDWalton
5th Gear Member
Thread Starter
 
JDWalton's Avatar
 
Join Date: Apr 2007
Location: CT
Posts: 2,612
Default

Well I've been a pain in the but to them, but American Muscle has a lot of manhours they are giving me so I have to thank them for that.
JDWalton is offline   Reply With Quote
Old 09-22-2015, 01:20 PM   #6
movielover40
4th Gear Member
 
Join Date: Aug 2015
Location: MI
Posts: 1,509
Default

Beautiful car there.
movielover40 is offline   Reply With Quote
Old 09-24-2015, 05:25 PM   #7
bl817
2nd Gear Member
 
bl817's Avatar
 
Join Date: Apr 2010
Location: Ft. Worth Tx
Posts: 369
Default

absolutely a beautiful car. I have a few questions and I'm not trying to be a d..k, just seeing what direction your going with your build. to me, it sounds like your halfway thru a FI setup. next being the fuel delivery and actual FI unit. 1. why have FI cams in a NA car? 2. Detroit Rockers from Brenspeed, why not use them as tuner? tunes for life from AM I'm thinking. your car may be starving for A/F until it gets wound up enough. since you have a tuner, I would install the OEM intake manifold and TB and tune back for those and see if your problems persist. put the stock COP back on to. aftermarkets are hit and miss. just my $.02 good luck.
bl817 is offline   Reply With Quote
Old 09-24-2015, 08:42 PM   #8
SpartaPerformance
4th Gear Member
 
SpartaPerformance's Avatar
 
Join Date: Apr 2010
Location: Long Island, New York
Posts: 1,291
Default

Sounds like a tuning problem to me too.
SpartaPerformance is offline   Reply With Quote
Old 09-24-2015, 09:47 PM   #9
bl817
2nd Gear Member
 
bl817's Avatar
 
Join Date: Apr 2010
Location: Ft. Worth Tx
Posts: 369
Default

you've got a great car and it seems you've put a few things on it that it doesn't need quite yet
bl817 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2014 Sterling Gray Track Pack GT spectreman Mustangs For Sale 23 03-31-2016 10:26 PM
Did a few mods this summer... drfister 2005-2014 Mustangs 9 09-04-2015 08:47 AM
Installed SF3/X3 for a 2005 mustang GT on a 2009 mustang V6. 'stangdude 4.6L V8 Technical Discussions 5 08-12-2015 02:27 PM
Need Help Diagnosing Have Codes (Confused) djbigskrilla 2005-2014 Mustangs 13 08-11-2015 01:59 PM
Trans issues codes P0732 P0735 P0775 Mnuckolls 4.0L V6 Technical Discussions 3 08-09-2015 09:54 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 12:19 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.