Backfire on hard accel at 4000 rpm - Page 2 - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Reload this Page >

Backfire on hard accel at 4000 rpm

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Backfire on hard accel at 4000 rpm

Reply

 
 
 
Old 07-20-2006, 11:32 PM
  #11  
CT5Ohh
1st Gear Member
 
Join Date: May 2006
Location:
Posts: 56
Default RE: Backfire on hard accel at 4000 rpm

Check the mass air sensor, I had unplugged mine when i had to do some work and forgot to plug it in. It started and drove alright until i hit the gas. It did that chugging/cutting out thing.
CT5Ohh is offline  
Reply With Quote
Old 07-21-2006, 02:09 AM
  #12  
Erik90LX5.0
Thread Starter
 
Join Date: Sep 2005
Posts: 18
Default RE: Backfire on hard accel at 4000 rpm

Ithink i figured it out , I put it on the scope at work and it showed #3 cylinder had different firing pattern then the other cylinders.looks like posssible restricted injector.that probably flows ok for idle and cruise but under load is too lean.
Erik90LX5.0 is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Stone629
The Racers Bench
66
06-02-2016 09:52 PM
UrS4
S197 Handling Section
10
10-03-2015 06:23 AM
guitarman376
4.6L (1996-2004 Modular) Mustang
0
09-30-2015 05:54 PM
CS2007
General Tech
7
09-29-2015 07:38 PM
lmurf60
4.6L (1996-2004 Modular) Mustang
1
09-24-2015 10:07 PM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory