Running hott and acting sluggest!!!!!! - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Reload this Page >

Running hott and acting sluggest!!!!!!

Notices
5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Running hott and acting sluggest!!!!!!

Reply

 
 
 
Old 09-11-2006, 05:28 PM
  #1  
5.0GTConveritbleGuy
Thread Starter
 
Join Date: Jun 2006
Location:
Posts: 28
Default Running hott and acting sluggest!!!!!!

Ok i drive a 89 GT converitble and i replaced the T stat with a 195* and put new collant in her, and she is still running in the hight normal range, to the point where i have to drive with the heat on full blast and not doing anytype of driving fast or any smashin, or it will go up. 2 days ago i just let it go up and in started making the loud *** rattiling sound and the temp was close to the red, above the N on the gage, so i pulled over and popped the hood and turned the heat on and after about 2-4 minutes it stopped. I dont understand whats going on and also when it gets hott its gets real sluggest, to the point where that day i put it to the floor and it barley went anywhere. It took a whlie like a good 10sec for it to get going fast. So can anyboys please tell me what could be possible be going on!!!!!!
5.0GTConveritbleGuy is offline  
Reply With Quote
Old 09-11-2006, 06:51 PM
  #2  
93must
3rd Gear Member
 
Join Date: Jun 2006
Location: Oregon
Posts: 598
Default RE: Running hott and acting sluggest!!!!!!

Could be a blown heaed gasket! Check your oil and see if there is any water or anti freeze in it. It will be a milky color if there is any! Your car running hot like that will really kill your HP.
93must is offline  
Reply With Quote
Old 09-11-2006, 06:54 PM
  #3  
leadfootdriver
2nd Gear Member
 
Join Date: May 2004
Location:
Posts: 298
Default RE: Running hott and acting sluggest!!!!!!

When your car car gets to like 190* it goes into a low performance mode; even the A/C won't work. A 180 T-stat is a better choice if your car runs hot.
leadfootdriver is offline  
Reply With Quote
Old 09-11-2006, 07:00 PM
  #4  
MEM 302 5.0L
3rd Gear Member
 
Join Date: Aug 2006
Location: MO
Posts: 805
Default RE: Running hott and acting sluggest!!!!!!

i put an electric fan in mine once...and (it wasnt very good) ...it lugged my alternator and battery down and wasnt cooling right...and it made my car sluggish ...and the a/c quit working....so i just put the stock clutch fan bak in.........i doubt that helps ne..but just sayin...
MEM 302 5.0L is offline  
Reply With Quote
Old 09-11-2006, 09:09 PM
  #5  
fordboyyfm
2nd Gear Member
 
Join Date: Jun 2006
Location:
Posts: 244
Default RE: Running hott and acting sluggest!!!!!!

did you drain the coolant from the radiator? how did it look, did it drain out real slow or normal. radiator could be clogged. i would also make sure the fan is working properly. make sure it doesnt spin really easy (if its the stock) or if you have electric make sure its working good.
fordboyyfm is offline  
Reply With Quote
Old 09-11-2006, 09:19 PM
  #6  
PONY GUY
4th Gear Member
 
Join Date: Aug 2006
Location: Cape May County, NJ
Posts: 1,097
Default RE: Running hott and acting sluggest!!!!!!

you might have a air bubble in the system . Jack the front up and take a rad cap off and let it run for a while till th coolant over flows and the system burps
PONY GUY is offline  
Reply With Quote
Old 09-11-2006, 09:36 PM
  #7  
Sk8trfred
2nd Gear Member
 
Join Date: Mar 2004
Location: Dartmouth, MA
Posts: 160
Default RE: Running hott and acting sluggest!!!!!!


ORIGINAL: MEM 302 5.0L

i put an electric fan in mine once...and (it wasnt very good) ...it lugged my alternator and battery down and wasnt cooling right...and it made my car sluggish ...and the a/c quit working....so i just put the stock clutch fan bak in.........i doubt that helps ne..but just sayin...
you wouldn't happen to be selling that fan are you? if it's still around that is
Sk8trfred is offline  
Reply With Quote
Old 09-11-2006, 09:43 PM
  #8  
MEM 302 5.0L
3rd Gear Member
 
Join Date: Aug 2006
Location: MO
Posts: 805
Default RE: Running hott and acting sluggest!!!!!!

it quit working....lol....the fan motor locked up
MEM 302 5.0L is offline  
Reply With Quote
Old 09-12-2006, 05:40 PM
  #9  
5.0GTConveritbleGuy
Thread Starter
 
Join Date: Jun 2006
Location:
Posts: 28
Default RE: Running hott and acting sluggest!!!!!!

Alright thanks everybody, ima try what y'all have suggested to me and ill let y'll know what happeneds.
5.0GTConveritbleGuy is offline  
Reply With Quote
Old 09-12-2006, 05:55 PM
  #10  
vristang
4th Gear Member
 
Join Date: Feb 2006
Location: Seattle, WA
Posts: 1,375
Default RE: Running hott and acting sluggest!!!!!!


ORIGINAL: 5.0GTConveritbleGuy

Alright thanks everybody, ima try what y'all have suggested to me and ill let y'll know what happeneds.
Start out by pulling the codes.
vristang is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
carid
General Tech
1
07-08-2016 10:55 AM
heslekrants
Street/Strip
11
09-23-2015 05:02 PM
uedlose
Parts For Sale
0
09-10-2015 04:30 PM
96stang3.8
V6 (1994-2004) Mustangs
1
09-10-2015 07:42 AM
zanemoseley
2005-2014 Mustangs
6
09-06-2015 01:58 PM


Thread Tools
Search this Thread
Quick Reply: Running hott and acting sluggest!!!!!!


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.