wierd problem - MustangForums.com

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Thread Tools Search this Thread
Old 09-07-2007, 07:23 AM   #1
4th Gear Member
Thread Starter
Join Date: Apr 2006
Posts: 1,174
Default wierd problem

ok so i took my dash off and finally got my blinkers working. i was moving the multifunction switch and when i turn on my highbeams it turns on the fuel pump like when you first turn on the ignition.
blk40th is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
2007 Won't stay running -- Possible electric problem Seanam V6 S197 General Discussion 5 10-04-2015 10:15 AM
1991 mustang vibration problem mdj89 5.0L (1979-1995) Mustang 7 09-23-2015 08:49 AM
1996 GT Studdering problems.. Need Help stangin1996gt 4.6L (1996-2004 Modular) Mustang 0 09-21-2015 11:01 AM
O2 sensors Big Al's 03 Mach 1 Section 4 09-21-2015 07:59 AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 02:57 PM.

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.