88 gt is dying every time i put gas in - MustangForums.com

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Thread Tools Search this Thread
Old 12-15-2007, 09:26 PM   #1
1st Gear Member
Thread Starter
Join Date: Dec 2007
Location: CA
Posts: 62
Default 88 gt is dying every time i put gas in

i just bought a 88 gt and i drove it 60 miles home with no problem. i put gas in and as soon as i left the station it died.it started up again and died.i left it for a few hours and then it started back up with no problem.today i put more gas in it because it was running fine and i wanted to see if it would happen again and it did the same thing.it wouldn't start for about a hour and then started right up.does anyone have any idea what the problem could be?
anrtman is offline   Reply With Quote
Old 12-15-2007, 09:59 PM   #2
5th Gear Member
Join Date: Feb 2006
Posts: 3,768
Default RE: 88 gt is dying every time i put gas in

I don't know how the tank ventilation is on cars, but I've had a motorcycle act like that because the tank vent was plugged. It vaporlocked. I know there is a charcoal canister and purge solenoid relating to venting gas fumes on our cars. It could have something to do with that. You may also have a piece of trash floating around in your tank, blocking the pickup. Or you may have a bad fuel filter or intermittent pump. These are just guesses. Good luck.
Twisted is offline   Reply With Quote
Old 12-17-2007, 04:00 PM   #3
Join Date: Dec 2007
Posts: 36
Default RE: 88 gt is dying every time i put gas in

I have to agree with the above... Sounds like a vapor lock situation.... But I thought that they over came that with the return line.....
I would check your fuel return line and see......

Just a thought.

93nitrousLX is offline   Reply With Quote
Old 12-17-2007, 08:44 PM   #4
1st Gear Member
Join Date: Dec 2006
Posts: 80
Default RE: 88 gt is dying every time i put gas in

Does the gas tank hiss when you remove the gas cap? - This would hint at built up pressure in the tank and a non-working vent system.

When you say it won't start ...do you hear the pump whine and attempt to prime the line with the key on engine off? If you don't even hear a whine it could be the pump on its way out or an issue in the electrical system (or relay).
richs347 is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Oil separator rubber seal question jesse1125 AmericanMuscle.com 4 08-26-2015 02:34 PM
Underhood Fuse #47 - Disaster waiting to happen jpplaw 4.6L V8 Technical Discussions 0 08-22-2015 09:29 PM
2002 3.8 electric problem daytooday General Tech 0 08-16-2015 08:22 AM
Need Help Diagnosing Have Codes (Confused) djbigskrilla 2005-2014 Mustangs 13 08-11-2015 12:59 PM
94 gt bucking / jerking on decel dfw692 5.0L (1979-1995) Mustang 4 08-07-2015 11:53 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 02:43 AM.

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.