finally got the timing down - Page 2 - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Reload this Page >

finally got the timing down

Notices
5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

finally got the timing down

Reply

 
 
 
Old 08-29-2008, 10:38 PM
  #11  
calfroper_06
4th Gear Member
Thread Starter
 
calfroper_06's Avatar
 
Join Date: Jul 2008
Location: texas
Posts: 1,175
Default

ok i konw what your talking about, its good im pretty, sure the hazards still work, does that mean the relay is good
calfroper_06 is offline  
Reply With Quote
Old 08-29-2008, 10:40 PM
  #12  
mjr46
D.R. THE PATHETIC DORK
 
mjr46's Avatar
 
Join Date: Jun 2007
Location: West Virginia
Posts: 30,809
Default

no because there is a seperate one I believe for the turn signals
mjr46 is offline  
Reply With Quote
Old 08-29-2008, 10:44 PM
  #13  
calfroper_06
4th Gear Member
Thread Starter
 
calfroper_06's Avatar
 
Join Date: Jul 2008
Location: texas
Posts: 1,175
Default

kool ill change tomarrow and see if it thats it
calfroper_06 is offline  
Reply With Quote
Old 08-29-2008, 11:08 PM
  #14  
mjr46
D.R. THE PATHETIC DORK
 
mjr46's Avatar
 
Join Date: Jun 2007
Location: West Virginia
Posts: 30,809
Default

make sure you get the right one changed
mjr46 is offline  
Reply With Quote
Old 08-30-2008, 02:59 PM
  #15  
calfroper_06
4th Gear Member
Thread Starter
 
calfroper_06's Avatar
 
Join Date: Jul 2008
Location: texas
Posts: 1,175
Default

i changed it nothing new, but i pulled the turn signal switch so i could get a test light on it, put it next to the car and a few minutes later steped back and crunch, lol so looks like im getting a new one anyway, 106 buck was all it was lol. this stuff adds up quick, plus i have to wait its an "order only item" lol
calfroper_06 is offline  
Reply With Quote
Old 08-31-2008, 10:26 PM
  #16  
calfroper_06
4th Gear Member
Thread Starter
 
calfroper_06's Avatar
 
Join Date: Jul 2008
Location: texas
Posts: 1,175
Default

got a new oem switch on order but i bypassed the connector through the harness and the blinkers work so im pretty sure it was the switch thanks for the help mjr46
calfroper_06 is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
carid
General Tech
1
07-08-2016 10:55 AM
mungodrums
5.0L GT S550 Tech
7
10-07-2015 05:01 AM
StalkerGT
5.0L (1979-1995) Mustang
13
09-25-2015 03:41 PM
JimC
Off Topic
22
09-11-2015 09:00 PM
Pyrate Dave
5.0L (1979-1995) Mustang
8
09-10-2015 08:30 PM


Thread Tools
Search this Thread
Quick Reply: finally got the timing down


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.