dizzy question and pic - Page 2 - MustangForums.com


5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-15-2008, 04:05 AM   #11  
crusin92red5.0
3rd Gear Member
Thread Starter
 
Join Date: Jul 2005
Location: sleeping with the enemy
Posts: 998
Default

Quote:
Originally Posted by PRO50SC View Post
Have you had anyone else look at the car?
NO.

i was suppose to take my car today to some guy here locally that specializes in mustangs. i got the car on a dolly that i rented and picked up my buddy, we called him and no answer. ended up drinking beer all day and periodically trying to call him.

believe me at this point i'm willing to pay someone to diagnose my problem,, but at the same time i don't want to take it to a shop that doesnt specialize in performance cars, and there are really none down here.

i'm gonna tinker with it a few more times, then i will hunt for a mechanic, THe said thing is i work at a shop,(lets say sears) so there are some qualified people there and they have no clue, i have friends that are mechanics at the post office and they have no clue, and i've search online for help. its almost like no one has ever had a problem like this. so i don't know
crusin92red5.0 is offline   Reply With Quote
Old 11-15-2008, 06:09 AM   #12  
Joel5.0
5th Gear Member
 
Joel5.0's Avatar
 
Join Date: Jan 2006
Location: Puerto Rico
Posts: 3,926
Default

Piston at TDC, the distributor should be installed as shown......
Attached Thumbnails
dizzy question and pic-08-13-08_1650.jpg  
Joel5.0 is offline   Reply With Quote
Old 11-15-2008, 07:29 AM   #13  
Timspony
SVT Section Moderator
 
Timspony's Avatar
 
Join Date: Jul 2008
Location: Burnt Hills, NY
Posts: 15,601
Default

Looks like the dizzy in the "small" pic is a tooth or 2 off...Best to find TDC and start over....
Timspony is offline   Reply With Quote
Old 11-15-2008, 09:53 AM   #14  
94Yellow50
4th Gear Member
 
Join Date: Jan 2007
Location: Illinois
Posts: 1,120
Default

you said its running like crap?..have you ever replaced the balancer? if not it may be shot and have spun some, thus causing you to time to an incorrect number.. so when you think your at 10 its really not, makin your mark seem off when you have it at what you think is 10
94Yellow50 is offline   Reply With Quote
Old 11-15-2008, 11:54 AM   #15  
calfroper_06
4th Gear Member
 
calfroper_06's Avatar
 
Join Date: Jul 2008
Location: texas
Posts: 1,175
Default

you need to start over, when you bring the number 1 back to tdc on the compression stroke, it should show 0* on your balancer, if not your balancer could have spun, then try and stab ou dizzy correctly, try to line the mark on the base of the dizzy with the mark on the edge on the dizzy hole on the block. then set timing
calfroper_06 is offline   Reply With Quote
Old 11-15-2008, 03:34 PM   #16  
94StinkinLincoln
5th Gear Member
 
94StinkinLincoln's Avatar
 
Join Date: Dec 2006
Location: louisiana
Posts: 2,763
Default

where are you located?
94StinkinLincoln is offline   Reply With Quote
Old 11-15-2008, 07:45 PM   #17  
crusin92red5.0
3rd Gear Member
Thread Starter
 
Join Date: Jul 2005
Location: sleeping with the enemy
Posts: 998
Default

Quote:
Originally Posted by 94StinkinLincoln View Post
where are you located?
Austin, Texas
crusin92red5.0 is offline   Reply With Quote
Old 11-15-2008, 07:51 PM   #18  
calfroper_06
4th Gear Member
 
calfroper_06's Avatar
 
Join Date: Jul 2008
Location: texas
Posts: 1,175
Default

i was just around there the other day
calfroper_06 is offline   Reply With Quote
Old 11-15-2008, 08:31 PM   #19  
94StinkinLincoln
5th Gear Member
 
94StinkinLincoln's Avatar
 
Join Date: Dec 2006
Location: louisiana
Posts: 2,763
Default

thats a few hrs away from here unfortunately.
94StinkinLincoln is offline   Reply With Quote
Old 11-15-2008, 08:33 PM   #20  
94StinkinLincoln
5th Gear Member
 
94StinkinLincoln's Avatar
 
Join Date: Dec 2006
Location: louisiana
Posts: 2,763
Default

that tf kit got a buddy of mine to a 12.97 launching from like 5-6k on a stock bottom end ... pretty much same car with an auto was very unimpressive imo.
94StinkinLincoln is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
95 gt dead fuel pump?? 9550 5.0L (1979-1995) Mustang 10 10-26-2015 05:01 PM
Noob needs help! 86 mustang svo motor swapped to 71 5_speed carb 302 v8 jaiidutch Motor Swap Section 2 09-14-2015 10:29 AM
Car meet and cruise Gabe_mlcc Mustang News, Concepts, Rumors & Discussion 0 09-07-2015 11:56 PM
Help! Metra 70-5521 AMP Harness Install cbird1177711 2005-2014 Mustangs 2 09-03-2015 08:43 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 10:44 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.