88 Mustang GT Question - MustangForums.com

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

88 Mustang GT Question

Reply

 
 
 
Old 08-08-2009, 06:05 PM
  #1  
pimp2303
2nd Gear Member
Thread Starter
 
Join Date: Jan 2008
Location:
Posts: 227
Default 88 Mustang GT Question

I have a 88 mustang i just bought and it has no brake lights or turn signals. just curious as to what could be the cause of this. it has headlights and running lights just no brakes lights and turn signal light. Do these model have a Turnsignal switch if so is it located inside the steering wheel like older models. thanks
pimp2303 is offline  
Reply With Quote
Old 08-08-2009, 06:15 PM
  #2  
mattdel
6th Gear Member
 
mattdel's Avatar
 
Join Date: Nov 2006
Location: Spfld, MA
Posts: 9,240
Default

Verify that you have reverse lights, as the turn signals and reverse lights are on the same fuse.
Check the bulbs? Test the switches?
mattdel is offline  
Reply With Quote
Old 08-08-2009, 06:36 PM
  #3  
pimp2303
2nd Gear Member
Thread Starter
 
Join Date: Jan 2008
Location:
Posts: 227
Default

i will check the reverse lights, and the car has all new fuses and still nothing
pimp2303 is offline  
Reply With Quote
Old 08-09-2009, 01:29 AM
  #4  
lxman1
4th Gear Member
 
Join Date: Jan 2008
Location: Louisville, Ky.
Posts: 1,326
Default

It has the multifunction switch in the column. Do the emergency flashers work?
lxman1 is offline  
Reply With Quote
Old 08-09-2009, 09:13 AM
  #5  
mjr46
D.R. THE PATHETIC DORK
 
mjr46's Avatar
 
Join Date: Jun 2007
Location: West Virginia
Posts: 30,808
Default

it could have a bad turn signal flasher and for the inoperative brake lights I'd check the switch down on the pedal
mjr46 is offline  
Reply With Quote
Old 08-09-2009, 12:32 PM
  #6  
pimp2303
2nd Gear Member
Thread Starter
 
Join Date: Jan 2008
Location:
Posts: 227
Default

the car has no reverse lights also... think the turn signal flasher went bad or could it be the multifunction switch on the column. what would make the brake lights not work. i also noticed that the windshield wipers motor is missing, could this have anything to do with it since the multifunction switch controls those. or it has nothing at all..

Last edited by pimp2303; 08-09-2009 at 12:35 PM.
pimp2303 is offline  
Reply With Quote
Old 08-09-2009, 12:51 PM
  #7  
mattdel
6th Gear Member
 
mattdel's Avatar
 
Join Date: Nov 2006
Location: Spfld, MA
Posts: 9,240
Default

Verify that you have power to the individual circuits with a test light/volt meter.

mattdel is offline  
Reply With Quote
Old 08-09-2009, 05:30 PM
  #8  
pimp2303
2nd Gear Member
Thread Starter
 
Join Date: Jan 2008
Location:
Posts: 227
Default

i will go buy a test light tomorrow, and start my search for were the fault is.
pimp2303 is offline  
Reply With Quote
Old 08-09-2009, 05:57 PM
  #9  
BlackStang87GT
 
BlackStang87GT's Avatar
 
Join Date: May 2008
Location: NY
Posts: 11
Default

Test the fuses for eerything. my lights had the same problem, ended up being a fuse problem.
BlackStang87GT is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Diode Dynamics
Vendor For Sale / Group Buy Classifieds
5
02-28-2018 10:39 AM
ding56
Classic Mustangs (Tech)
3
08-14-2015 02:40 AM
StangMuscle
Motor Swap Section
0
08-12-2015 07:27 AM
$A_Money$81
V6 (1994-2004) Mustangs
1
08-11-2015 01:30 PM
daytooday
Motor Swap Section
2
08-11-2015 09:22 AM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory