93 EEC Relay - MustangForums.com

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

93 EEC Relay

Reply

 
 
 
Old 12-28-2009, 12:11 AM
  #1  
93GuAcAStang
Thread Starter
 
93GuAcAStang's Avatar
 
Join Date: Dec 2009
Location: Florida
Posts: 19
Default 93 EEC Relay

Hello.
I've been having a common issue with my fuel pump not priming.
I drove up to my work to get something on a sunday, pulled up, turned off the engine, went inside, came out, turn the key, no fuel pump.
I hadn't worked on my car in a couple weeks so I dont think its anything I have done to cause it.
I actually have a thread in my gaming forum I can link (if the admins dont mind) that pretty much chronicles every major thing I've done to my car since Ive had it.

My friend who is a mechanic came over and we tested a lot of the electrical.
We eliminated the pump and FP relay as the culprits.
With the key in the on position Im only getting 3.5v at the pump.

Its pretty much narrowed down to a few things.
1. fuse able link
2. short in the wiring
3. EEC relay
4. computer

I got a new EEC relay, and my mechanic friend says its under the drivers side dash, but I cant seem to find it. Either that, or NAPA sold me the wrong relay.
So, my main question is, where exactly is the EEC relay on a 93 GT?
93GuAcAStang is offline  
Reply With Quote
Old 12-28-2009, 01:01 AM
  #2  
luckythirteen13
6th Gear Member
 
luckythirteen13's Avatar
 
Join Date: May 2004
Location: las vegas, nv
Posts: 9,088
Default

are you seeing 3.5v while the car is running or just during the times it wouldnt prime?
luckythirteen13 is offline  
Reply With Quote
Old 12-28-2009, 02:45 AM
  #3  
93GuAcAStang
Thread Starter
 
93GuAcAStang's Avatar
 
Join Date: Dec 2009
Location: Florida
Posts: 19
Default

It wont start. The fuel pump wont prime.
Its 3.5v at the inertia switch when I turn the ignition to on.
Its a new inertia switch btw.
93GuAcAStang is offline  
Reply With Quote
Old 12-30-2009, 12:48 AM
  #4  
93GuAcAStang
Thread Starter
 
93GuAcAStang's Avatar
 
Join Date: Dec 2009
Location: Florida
Posts: 19
Default

....no one knows?
93GuAcAStang is offline  
Reply With Quote
Old 12-30-2009, 07:21 AM
  #5  
Joel5.0
5th Gear Member
 
Joel5.0's Avatar
 
Join Date: Jan 2006
Location: Puerto Rico
Posts: 3,926
Default

1. EEC relay is behind the passenger side kick-panel.



2. Assuming you have spark present when engine is cranked, follow part two of the procedure described in this How to Solve an EFI No Start writeup and LUK.
Joel5.0 is offline  
Reply With Quote
Old 12-31-2009, 01:06 AM
  #6  
93GuAcAStang
Thread Starter
 
93GuAcAStang's Avatar
 
Join Date: Dec 2009
Location: Florida
Posts: 19
Default

Thank you sir very much!

May you be blessed with 15 virgins.
Or, if you're married, may you be blessed with free SPEED channel and/or free NFL channel
93GuAcAStang is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
firehorse02
Parts For Sale
1
11-16-2015 11:28 AM
Urambo Tauro
5.0L (1979-1995) Mustang
6
10-05-2015 09:37 PM
Seanam
V6 S197 General Discussion
5
10-04-2015 10:15 AM
1996cobraconvertible
SVT Forums
3
09-30-2015 02:01 PM
schecterplayer
5.0L (1979-1995) Mustang
3
09-23-2015 08:38 AM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory