1995 GT Engine Lacking Power - Page 2 - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Reload this Page >

1995 GT Engine Lacking Power

Notices
5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

1995 GT Engine Lacking Power

Reply

 
 
 
Old 03-07-2010, 08:40 PM
  #11  
[email protected]
Thread Starter
 
Join Date: Mar 2010
Location: Minnesota
Posts: 31
Default

Well either cleaning the MAF sensor did it or the cat is partially plugged. I reset all of the codes then ran it down the road. Now it pulls "Decent" up to 5k. After that I did the KOEO and KOER and everything came back clean with NO errors. It still feels doggy so I am going to point at the Cats. Now I need to decide "What" I am going to do with them
mxz71@hotmail.com is offline  
Reply With Quote
Old 03-07-2010, 09:37 PM
  #12  
mjr46
D.R. THE PATHETIC DORK
 
mjr46's Avatar
 
Join Date: Jun 2007
Location: West Virginia
Posts: 30,809
Default

drive the car around for a day or two so that the ecm can now update the adaptive strategy for fuel management now that the maf is clean and won't be sending skewed readings to the ecm for fuel management calculations.
mjr46 is offline  
Reply With Quote
Old 03-07-2010, 09:59 PM
  #13  
sn95_331_GT_ yellow
5th Gear Member
 
sn95_331_GT_ yellow's Avatar
 
Join Date: Mar 2008
Location: CT
Posts: 2,394
Default

its never going to pull past 5 no matter what you do to it now...

mine was barely worth going to 5500 on, the heads MURDER the power on these things...

drive it around for the time being and then start saving up for HCI and have some fun

if at all possible check your A/F ratio, these cars are notorious for burning VERY lean at WOT (mine was 16.2:1, Adder had like 15.5:1)... a new fuel pump and Aeromotive FPR did the trick for me...
sn95_331_GT_ yellow is offline  
Reply With Quote
Old 03-08-2010, 04:52 PM
  #14  
Danny_Boy
 
Danny_Boy's Avatar
 
Join Date: Feb 2010
Location: Western New York
Posts: 10
Default

331_GT,what would be a better heads upgrade for someone on a budget?

I was thinking maybe the heads off a Ford Explorer.From what i gather they are of the GT40 design along with their intake manifold set up.

I have always thought that the E7 heads were pretty good.I had an old '91 P72 Crown Victoria with the lo-po 5.0 V8.Some people told me that swapping out the E6 heads for E7's would be a good upgrade.
Danny_Boy is offline  
Reply With Quote
Old 03-08-2010, 07:33 PM
  #15  
sn95_331_GT_ yellow
5th Gear Member
 
sn95_331_GT_ yellow's Avatar
 
Join Date: Mar 2008
Location: CT
Posts: 2,394
Default

look for a used set of TF heads.

dont bother buying AFR's or anything else...

maybe a set of Canfields if you can find them cheap...
sn95_331_GT_ yellow is offline  
Reply With Quote
Old 03-08-2010, 08:03 PM
  #16  
Danny_Boy
 
Danny_Boy's Avatar
 
Join Date: Feb 2010
Location: Western New York
Posts: 10
Default

^ Thanks for the advice 331_GT.

I wish i had the same rims that you have on your yellow GT,i friggin love them rims....

You ever think about putting 'Boss shinoda' graphix on your car? I was always a huge fan of the '94-'95 yellow boss shinoda Mustangs.I got a few pix of one back when i was 17 years old @ a local car show.

Last edited by Danny_Boy; 03-08-2010 at 08:07 PM.
Danny_Boy is offline  
Reply With Quote
Old 03-09-2010, 11:27 AM
  #17  
sn95_331_GT_ yellow
5th Gear Member
 
sn95_331_GT_ yellow's Avatar
 
Join Date: Mar 2008
Location: CT
Posts: 2,394
Default

i HATED those rims...

theyre on a buddies LX notch, painted black, and it actually looks pretty good...

im rocking some silver FRPP 2000 Cobra R's right now, and im gonna get a set of black 2010 GT500's from American Muscle...
sn95_331_GT_ yellow is offline  
Reply With Quote
Old 03-09-2010, 12:12 PM
  #18  
[email protected]
Thread Starter
 
Join Date: Mar 2010
Location: Minnesota
Posts: 31
Default Cats Plugged

Ok... My cats are toast... Are there O2 Sensors after the Cats on a 95 GT? If not I might just "Make them work"
mxz71@hotmail.com is offline  
Reply With Quote
Old 03-09-2010, 05:44 PM
  #19  
sn95_331_GT_ yellow
5th Gear Member
 
sn95_331_GT_ yellow's Avatar
 
Join Date: Mar 2008
Location: CT
Posts: 2,394
Default

we only have 2 O2 sensors, one on each side right after the manifold.

OBDII has the 02's after the cats...

just do the exhaust now anyways...

MAC longtubes, OR X, and your choice of mufflers...
sn95_331_GT_ yellow is offline  
Reply With Quote
Old 03-12-2010, 06:51 PM
  #20  
[email protected]
Thread Starter
 
Join Date: Mar 2010
Location: Minnesota
Posts: 31
Default Car is still doggy

I had the back pressure tested today and there are definitely no restrictions in the exhaust. There is something else going on here??? Again it is very doggy... Especially when not fully up to temp. It does not pull hard at all. I am getting NO codes. All plugs/wires/cap/rotor are new. What else would do this? Timing maybe??
mxz71@hotmail.com is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Urambo Tauro
New Member Area
12
12-17-2016 04:30 PM
ShaneB26154
4.6L (1996-2004 Modular) Mustang
34
05-15-2016 10:30 AM
Gary Ugarek
4.6L (1996-2004 Modular) Mustang
63
12-11-2015 03:01 PM
Urambo Tauro
5.0L (1979-1995) Mustang
22
09-07-2015 01:47 PM
djbigskrilla
2005-2014 Mustangs
13
08-11-2015 01:59 PM


Thread Tools
Search this Thread
Quick Reply: 1995 GT Engine Lacking Power


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.