1995 GT rough idle, runing rich - MustangForums.com



5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 06-02-2010, 03:33 PM   #1
EmilsGT
Thread Starter
 
Join Date: Jun 2010
Location: Riga
Posts: 2
Default 1995 GT rough idle, runing rich

Hi
I have 1995 mustang GT and its idling very rough (cold and warm no difference) and also its rough driving on low rpms
and its going very rich smells like fuel and have big amount of black smoke from time to time(cold/warm). I have no cats but it had idle problem even before i get rid of the cats also i have k&n drop in filter set i think i started to feel those problems more when i did those upgrades.
koer test shows that (136 (R) Oxygen sensor not switching/system lean Left or Front HO2S) also i didn't remove the smog pump so its still pumping air in the exhaust so maybe that's why car has problems (is it possible that now when cats are out and there is less resistance in exhaust smog pump is just stealing the air from intake and because it takes it after the maf it corrupts the readings and car goes rich, or that doesn't matter) also what will happen if i will remove oxygen sensors from exhaust?
I already cleaned the maf and i think it did little improvement and car isn't going so rich but it still smells very rich and there is no improvement on rough idle and low rpms.

any help will be appreciated and sorry for bad English
Emils
EmilsGT is offline   Reply With Quote
Old 06-04-2010, 01:14 PM   #2
02WhiteGTVert
3rd Gear Member
 
02WhiteGTVert's Avatar
 
Join Date: May 2007
Location:
Posts: 910
Default

replace your o2 sensors.
02WhiteGTVert is offline   Reply With Quote
Old 06-04-2010, 01:16 PM   #3
02WhiteGTVert
3rd Gear Member
 
02WhiteGTVert's Avatar
 
Join Date: May 2007
Location:
Posts: 910
Default

Quote:
Originally Posted by EmilsGT View Post
what will happen if i will remove oxygen sensors from exhaust?


you will have two exhaust leaks, and your car will run like ***.
02WhiteGTVert is offline   Reply With Quote
Old 06-04-2010, 06:11 PM   #4
EmilsGT
Thread Starter
 
Join Date: Jun 2010
Location: Riga
Posts: 2
Default

ok will try new O2 i hope that will help. but can i try to disconnect them i heard that some guys had same problems and after disconnecting O2 there was improvement. And thx for info
EmilsGT is offline   Reply With Quote
Old 06-04-2010, 10:04 PM   #5
AdderMk2
Banned
 
Join Date: Dec 2005
Location: Lil' Rhody
Posts: 22,376
Default

your car needs them. you will see no improvement
AdderMk2 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
TNT, New PB TCStangerv6 Street/Strip 12 10-11-2015 05:57 PM
1994-1995 ODBII Port Urambo Tauro 5.0L (1979-1995) Mustang 6 10-05-2015 09:37 PM
Starting Issue svfetter 5.0L (1979-1995) Mustang 9 10-05-2015 11:39 AM
4 Valve Head questions GimpyHSHS 4.6L (1996-2004 Modular) Mustang 6 10-01-2015 09:01 AM
Rough idle and vibrating 4cylinderplus2 V6 (1994-2004) Mustangs 9 09-30-2015 05:26 PM


Tags
1994, 1995, 95, ford, gt, idle, idles, idling, low, miss, mustang, problems, rich, rough, rpms, started

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 02:04 PM.