New engine, oil pressure and lifter questions. - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Reload this Page >

New engine, oil pressure and lifter questions.

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

New engine, oil pressure and lifter questions.

Reply

 
 
 
Old 10-20-2010, 07:17 PM
  #1  
thundermax
Thread Starter
 
Join Date: Aug 2010
Location: FL
Posts: 3
Default New engine, oil pressure and lifter questions.

I rebuilt my engine few months back. Has new cam bearings, .10/.10 crank with matching bearings. Stock replacement oil pump and pickup tube.
Cold start I get 53-55 psi of oil pressure, warm idle at 800rpm about 28-30psi. Driving on highway warmed up: 2000-2200rpm its at 46-48psi

Before rebuild: Would only get 35psi cold start and after 10 minutes would drop to 5psi of oil pressure. The rod/main bearings were shot, so was the crank, oil pickup had pieces of timing cover in it. So everything was replaced with new stock parts, other than lifters and valvetrain.

The motor is all stock internally, all galley plugs are good, bearing clearances are between 2.5 to 3 thousanths.
Also I have intermittent tick from driver's side of the engine it has had it since day one after rebuild, I didn't replace any lifters during rebuild.

Question is: Will worn out lifters cause loss of oil pressure? and are my oil pressure readings normal for a stock 5.0 with stock volume pump. I am running 4.5 qts of 5w30 and 1/2 qt of lucas oil stabilizer.

Currently engine has 1900 miles, I pulled valve covers off at 1000 miles and checked all of the rockers and they were fine.
I have stock stamped steel rockers torqued to 22 ft. lbs.
I've searched and found a lot of people are getting 60+psi after rebuild, so I don't know if I should be concerned about this.
thundermax is offline  
Reply With Quote
Old 10-20-2010, 07:47 PM
  #2  
Bubba 95SN
4th Gear Member
 
Join Date: Apr 2009
Location: N.C.
Posts: 1,893
Default

40-60 hot at 2000 rpm is normal. Why 5-30 instead of 10-30? As much heat as in Florida I'd be using 10-30.
Bubba 95SN is offline  
Reply With Quote
Old 10-20-2010, 07:59 PM
  #3  
mjr46
D.R. THE PATHETIC DORK
 
mjr46's Avatar
 
Join Date: Jun 2007
Location: West Virginia
Posts: 30,809
Default

your oil pressure is fine, as for the tick it could be and exhaust leak, or a lifter bleeding off
mjr46 is offline  
Reply With Quote
Old 10-20-2010, 08:47 PM
  #4  
tohoopty
4th Gear Member
 
tohoopty's Avatar
 
Join Date: Sep 2008
Location: point pleasant,west virginia
Posts: 1,212
Default

on my new rebuild i carry over 60 psi cold and it dont drop much below 60 when its warm.i run 10 40 in it and i wouldnt run lucas in it
tohoopty is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
67LimeCoupe
5.0L General Discussion
45
11-25-2015 08:55 PM
yurizx6r
5.0L (1979-1995) Mustang
49
09-07-2015 06:40 PM
inyadreems
Mustangs For Sale
2
08-21-2015 09:10 AM
ding56
Classic Mustangs (Tech)
3
08-14-2015 02:40 AM
yurizx6r
5.0L (1979-1995) Mustang
14
08-11-2015 07:50 AM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory