loss of power problems - MustangForums.com

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

loss of power problems

Reply

 
 
 
Old 12-04-2010, 03:56 PM
  #1  
dowe23
Thread Starter
 
Join Date: Mar 2010
Location: canada
Posts: 49
Default loss of power problems

alright i have an 88 5.0 and ever since i got it in the spring i've noticed a problem when you hold it to the floor.. its like it doesnt pull the way it should.. till about 35- 4000 rpm then kicks in.. i thought it was the fuel filter, changed that awhile back, helped some for about a week or so then the same thing again.. next guess was fuel pump.. i just droped the tank and im 90% sure it is a rather new fuel pump.. im going to change the pump and clean the tank, the car apart is a winter project so i was wondering if anybody might know what the problem could be if the new pump doesnt solve it while i have it apart.. thanks
dowe23 is offline  
Reply With Quote
Old 12-04-2010, 05:16 PM
  #2  
Bubba 95SN
4th Gear Member
 
Join Date: Apr 2009
Location: N.C.
Posts: 1,893
Default

Put a fuel pressure gauge on and answer yourself. Check for codes.
Bubba 95SN is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
musnicki
Classic Mustang General Discussion
8
09-23-2015 07:11 AM
needhelpplease
2005-2014 Mustangs
7
09-04-2015 09:59 AM
5.0 kevo
5.0L (1979-1995) Mustang
6
09-03-2015 06:24 PM
whatsup62
5.0L GT S550 Tech
1
09-03-2015 01:38 PM
sammyd16
V6 (1994-2004) Mustangs
2
08-30-2015 10:03 PM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory