No Turn Signals, I'm Stumped. - Page 2 - MustangForums.com


5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-13-2017, 10:23 PM   #11
Kendall.willis
 
Join Date: Mar 2017
Location: Washington
Posts: 2
Default

I have 94 Mustang 5.0 the blinkers don't flash & hazards do not work, when the hazard switch is pressed down and I put the blinker on the side its on has a constant light in the front and rear. I have changed the Blinker relay, the Multiswitch, All of the Lights, Fuses.
Has anyone else had this problem?
Kendall.willis is offline   Reply With Quote
Old 03-14-2017, 11:05 AM   #12
88 orangepeel notch
6th Gear Member
 
88 orangepeel notch's Avatar
 
Join Date: Mar 2010
Location: Wisconsin
Posts: 5,062
Default

Welcome to the forum.

But just a FYI, start a new thread with any issues your having. Hyjacking an older thread is frowned upon. It makes everyone read the entire thread again before getting to your post.

We've all done once.......... ONCE !!! lol

Have you tried swapping relays ? Hazards and turn signals relays can be swapped to narrow it down alittle.
88 orangepeel notch is offline   Reply With Quote
Old 03-14-2017, 11:15 AM   #13
Kendall.willis
 
Join Date: Mar 2017
Location: Washington
Posts: 2
Default

Quote:
Originally Posted by 88 orangepeel notch View Post
Welcome to the forum.

But just a FYI, start a new thread with any issues your having. Hyjacking an older thread is frowned upon. It makes everyone read the entire thread again before getting to your post.

We've all done once.......... ONCE !!! lol

Have you tried swapping relays ? Hazards and turn signals relays can be swapped to narrow it down alittle.

Thank you for the reply and the FYI! I am new to the forum, and I cannot post a new thread until I have Been a member for 30 days. Thank you for understanding! I have changed the Blinker relay, is there a separate relay for the hazard signals ?
Kendall.willis is offline   Reply With Quote
Old 03-15-2017, 08:53 AM   #14
88 orangepeel notch
6th Gear Member
 
88 orangepeel notch's Avatar
 
Join Date: Mar 2010
Location: Wisconsin
Posts: 5,062
Default

Yes there is, and you can swap them to see if this is a relay issue.

They aren't known for failing very often, but it did happen to me on another car.

Good luck
88 orangepeel notch is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Snow performance stage 2 MAF boos cooler install jwog666 Pipes, Boost & Juice 6 01-07-2018 08:16 AM
what are the odds - Service Engine Soon light lincolnshibuya V6 (1994-2004) Mustangs 9 12-08-2015 05:37 PM
04 Mach 460 system, Installed Aftermarket HU, No Highs/Tweeters breaking Audio/Visual Electronics 5 10-02-2015 02:27 PM
I should've known better ChampInSD 5.0L GT S550 Tech 13 10-02-2015 05:55 AM
seems like car doesn't have enough juice to turn over logan409 4.6L (1996-2004 Modular) Mustang 10 09-26-2015 08:43 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 11:27 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.