1990 5.0 dead - MustangForums.com



5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 09-08-2015, 05:15 AM   #1
1TUFF302
Thread Starter
 
Join Date: Mar 2009
Location: Ill
Posts: 23
Default 1990 5.0 dead

Took my car out last week drove about half hour and it died,no spark no gas smell can hear fuel pump prime,replaced the dist and TFI did no good.left car in lot came back with trailer and car started.got it back home and let it sit for 4 days,it stared up let it get hot was working fine,tested with scanner had some codes about no power to ecm.I ran a couple test with KOEO and then i got it now my code on scanner is 15 prom failure and yep will not start.Took out my chip and still will not start but I did get it to run a couple of times but ****y and died.Any body know were i can get my A9L repaired at.
1TUFF302 is offline   Reply With Quote
Old 09-08-2015, 08:19 AM   #2
88 orangepeel notch
6th Gear Member
 
88 orangepeel notch's Avatar
 
Join Date: Mar 2010
Location: Wisconsin
Posts: 5,062
Default

Sorry, I don't know of anyone around us that repairs them. When mine went bad, Autozone carried remanufactured ones for $100. That was 5-6 years ago though. Good luck

If you find any information in this fix, be sure to post back with an update as I've been seeing more and more ECMs failing lately and no real fix except taking your chance on eBay ones. Normally these computer's have had a very good reputation.
88 orangepeel notch is offline   Reply With Quote
Old 09-09-2015, 04:30 AM   #3
1TUFF302
Thread Starter
 
Join Date: Mar 2009
Location: Ill
Posts: 23
Default

ecm are on ebay but I think I am going to have it repaired.

Last edited by 1TUFF302; 09-10-2015 at 05:57 AM.
1TUFF302 is offline   Reply With Quote
Old 09-09-2015, 08:04 AM   #4
88 orangepeel notch
6th Gear Member
 
88 orangepeel notch's Avatar
 
Join Date: Mar 2010
Location: Wisconsin
Posts: 5,062
Default

OK, post back if you find a place that repairs them and the cost/warranty info.

Just to help the next guy out who may have similar problems. Good luck
88 orangepeel notch is offline   Reply With Quote
Old 09-11-2015, 03:40 PM   #5
silver91gt
5th Gear Member
 
Join Date: Mar 2005
Location:
Posts: 3,195
Default

check the fusible links for the ecm power before you replace anything.
silver91gt is offline   Reply With Quote
Old 09-11-2015, 04:28 PM   #6
1TUFF302
Thread Starter
 
Join Date: Mar 2009
Location: Ill
Posts: 23
Default

Quote:
Originally Posted by silver91gt View Post
check the fusible links for the ecm power before you replace anything.
when it sat for 4 days and started I dont think its the links plus when it happen the first time it started and sat I drove it up the trailer and checked all grounds.

Last edited by 1TUFF302; 09-11-2015 at 04:31 PM.
1TUFF302 is offline   Reply With Quote
Old 09-30-2015, 05:56 AM   #7
1TUFF302
Thread Starter
 
Join Date: Mar 2009
Location: Ill
Posts: 23
Default

well found a a9l computer for 100 bucks and it does start and run just have not taken it out for a drive yet.just over 300 bucks you can have them repaired,this was cheaper for me.
1TUFF302 is offline   Reply With Quote
Old 09-30-2015, 08:50 AM   #8
88 orangepeel notch
6th Gear Member
 
88 orangepeel notch's Avatar
 
Join Date: Mar 2010
Location: Wisconsin
Posts: 5,062
Default

Good to hear, thanks for the update. Was this a used ECM or remanufactured ?
88 orangepeel notch is offline   Reply With Quote
Old 10-31-2015, 03:23 PM   #9
Tribefan
2nd Gear Member
 
Tribefan's Avatar
 
Join Date: Apr 2014
Location: Waxhaw, NC
Posts: 445
Default

wrong thread. sorry

Last edited by Tribefan; 10-31-2015 at 03:25 PM.
Tribefan is offline   Reply With Quote
Old 11-05-2015, 04:20 AM   #10
1TUFF302
Thread Starter
 
Join Date: Mar 2009
Location: Ill
Posts: 23
Default

Quote:
Originally Posted by 88 orangepeel notch View Post
Good to hear, thanks for the update. Was this a used ECM or remanufactured ?
yes used,took out my old distributor and found the gear all most gone,trying to find out what gear to use for the x303 cam from ford.

i dont take it out much
1TUFF302 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Possible Clutch Issues..? Thunderball 4.6L (1996-2004 Modular) Mustang 15 11-23-2015 12:49 AM
1994-1995 ODBII Port Urambo Tauro 5.0L (1979-1995) Mustang 6 10-05-2015 10:37 PM
Starting a new project....could use some input. Matt's 95 Stang 5.0L (1979-1995) Mustang 2 10-05-2015 08:16 AM
New member 14gt_Track New Member Area 5 10-01-2015 03:47 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 06:04 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.