New Exhaust=Power Loss? - MustangForums.com

5.0L General Discussion This section is for non-tech specific information pertaining to 5.0L Mustangs.

New Exhaust=Power Loss?

Reply

 
 
 
Old 06-24-2008, 11:15 PM
  #1  
Stella94GT
3rd Gear Member
Thread Starter
 
Join Date: Dec 2006
Location: chicago
Posts: 875
Default New Exhaust=Power Loss?

i just got my long tubes, off road x, and dynomax super turbos installed and im pretty sure iv lost some power.. i cant break the tires loose as easy as i could before. its pretty upsetting. is this normal?
Stella94GT is offline  
Reply With Quote
Old 06-24-2008, 11:23 PM
  #2  
NoGo95GT
4th Gear Member
 
NoGo95GT's Avatar
 
Join Date: Aug 2007
Location: Texas
Posts: 1,788
Default RE: New Exhaust=Power Loss?

Since you are running a larger exhaust pipe and running no cats, you are losing backpressure. Because of this you have lost all of your low end torque, for higher rpm horsepower. You amy not feel any of that horsepower because you have a bottlenecked top end(heads, cam, and intake). Had the same problem when I added full exhaust and it was deffinetly noticable after I installed my off-road X.
NoGo95GT is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Galactic
Mustangs For Sale
9
03-30-2017 06:44 PM
SSRFUZZY
Members Other Vehicles
6
01-06-2016 08:22 PM
Pyrate Dave
5.0L (1979-1995) Mustang
8
09-10-2015 07:30 PM
Boostaddict
Lethal Performance
2
09-08-2015 09:56 PM
Emblazoned
General Tech
0
09-03-2015 10:45 PM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory