Front Blinkers & Hazards DONT work, Back Blinkers and hazards WORK - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang > 5.0L General Discussion
Reload this Page >

Front Blinkers & Hazards DONT work, Back Blinkers and hazards WORK

5.0L General Discussion This section is for non-tech specific information pertaining to 5.0L Mustangs.

Front Blinkers & Hazards DONT work, Back Blinkers and hazards WORK

Reply

 
 
 
Old 03-01-2013, 04:25 PM
  #1  
the_freshmaker5
Thread Starter
 
Join Date: Mar 2013
Location: mi
Posts: 2
Question Front Blinkers & Hazards DONT work, Back Blinkers and hazards WORK

I have a 1995 Convertible Mustang 5.0 manual. Neither of my front blinkers are working for turn signal or hazard but both work in the rear of the car. My fog lights work, brake lights work, tail lights work. I have HID headlights and one of them is out right now but the other works. Can anyone advise me on how to fix this? Thanks!
the_freshmaker5 is offline  
Reply With Quote
Old 03-01-2013, 08:23 PM
  #2  
mustangsneverdie
5th Gear Member
 
mustangsneverdie's Avatar
 
Join Date: Oct 2007
Location: Georgia
Posts: 2,624
Default

check your wires running to the multi function switch
mustangsneverdie is offline  
Reply With Quote
Old 03-01-2013, 10:44 PM
  #3  
the_freshmaker5
Thread Starter
 
Join Date: Mar 2013
Location: mi
Posts: 2
Cool Multi Function Switch

Thank you for the suggestion! That is the actual blinker handle correct and you want me to see if the connection is tight/good? Should I be using a volt meter on it or even at the blinker bulb connections? Is this pretty much the only thing it could be because i could order a new lever if none of this works. I hear there are flasher relays as well but im not sure if one of those were out that it would only cause my fronts blinkers to stop. Thanks
the_freshmaker5 is offline  
Reply With Quote
Old 03-01-2013, 11:38 PM
  #4  
mjr46
D.R. THE PATHETIC DORK
 
mjr46's Avatar
 
Join Date: Jun 2007
Location: West Virginia
Posts: 30,809
Default

you'll have to get a wiring diagram and test power into switch as well as that coming out of the switch to the lights, or just slap a new part on and cross your fingers
mjr46 is offline  
Reply With Quote
Old 03-03-2013, 01:37 PM
  #5  
holyshift
3rd Gear Member
 
holyshift's Avatar
 
Join Date: Jul 2007
Location: Sandusky,OH
Posts: 893
Default

Crazy as it may sound,look at your ignition switch too,I dont know for sure,but in my 88' I had a turn signal problem and my ignition switch in my column was super loose.
holyshift is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
svastano
2005-2009 S197 Appearance Section
25
07-16-2016 02:20 PM
jjwinel78
V6 (1994-2004) Mustangs
1
08-17-2015 04:34 PM
cvarner131
New Member Area
3
08-17-2015 08:38 AM
svtrosey
SVT Forums
4
08-15-2015 10:09 PM
djbigskrilla
2005-2014 Mustangs
13
08-11-2015 01:59 PM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory