why not to run a bypass filter with a dry sump setup - MustangForums.com



5.0L General Discussion This section is for non-tech specific information pertaining to 5.0L Mustangs.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-03-2013, 03:00 PM   #1
5.0kid
5th Gear Member
Thread Starter
 
5.0kid's Avatar
 
Join Date: Dec 2006
Location: The mitten
Posts: 2,524
Default why not to run a bypass filter with a dry sump setup

Cus your car will loose oil pressure on launch and still go 8.89
5.0kid is offline   Reply With Quote
Old 05-03-2013, 07:27 PM   #2
holyshift
3rd Gear Member
 
holyshift's Avatar
 
Join Date: Jul 2007
Location: Sandusky,OH
Posts: 893
Default

Hope ya got it figured out bud,some 8.70's coming your way.
holyshift is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
AODE Woes Pyrate Dave 5.0L (1979-1995) Mustang 8 09-10-2015 07:30 PM
Huge Savings from Lethal Performance.com!(Whipple, McLeod, Kooks, & MUCH MORE..) Boostaddict Lethal Performance 2 09-08-2015 09:56 PM
First Mustang 99' 3 differnt body kits installed TimeLord101 New Member Area 3 09-04-2015 09:27 AM
5.0 wont start condition 5.0 kevo 5.0L (1979-1995) Mustang 6 09-03-2015 06:24 PM
Best Place To Run Power Wire/Firewall '08 cbird1177711 2005-2014 Mustangs 3 09-02-2015 08:51 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 12:39 AM.