Notices
Classic Mustangs (Tech) Technical discussions about the Mustangs of yester-year.

Dashboarard / gauge lights shut off while driving

Old 06-24-2019, 09:58 PM
  #1  
theleeb
Thread Starter
 
Join Date: Jun 2009
Location: Maryland
Posts: 10
Default Dashboarard / gauge lights shut off while driving

Hi folks - I notice that after about 30 minutes of driving, the dashboard and gauge lights suddenly shut off. I am able to repeat the symptom. The engine seems to run a little hot and am thinking that maybe the heat is causing the issue?

Any ideas would be appreciated.
theleeb is offline  
Old 06-25-2019, 05:58 AM
  #2  
fastbackford351
Foghorn Leghorn
 
fastbackford351's Avatar
 
Join Date: Dec 2006
Location: I reside in a near constant state of amazment.
Posts: 2,822
Default

Dimes to doughnuts it's your head light switch.
fastbackford351 is offline  
Old 06-25-2019, 09:22 AM
  #3  
theleeb
Thread Starter
 
Join Date: Jun 2009
Location: Maryland
Posts: 10
Default

I see the switch doesn't cost much and appears that even I can install it. Thanks for the advice, I'll give it a try.
theleeb is offline  
Old 06-27-2019, 07:43 AM
  #4  
fastbackford351
Foghorn Leghorn
 
fastbackford351's Avatar
 
Join Date: Dec 2006
Location: I reside in a near constant state of amazment.
Posts: 2,822
Default

If you can find one, get an NOS switch. It'll cost more but the difference in quality between an NOS and a ChiCom special is night and day.
fastbackford351 is offline  
Old 06-28-2019, 10:40 AM
  #5  
theleeb
Thread Starter
 
Join Date: Jun 2009
Location: Maryland
Posts: 10
Default

New symptom - the headlights also went out while driving. I call this problem "Not Good". Maybe a faulty resistor in the switch that fails when it gets hot, who knows.

The shop replaced the switch about 5 months ago. Weird.

Sorry, but was does "NOS" mean?

Thanks.
theleeb is offline  
Old 06-30-2019, 08:42 PM
  #6  
fastbackford351
Foghorn Leghorn
 
fastbackford351's Avatar
 
Join Date: Dec 2006
Location: I reside in a near constant state of amazment.
Posts: 2,822
Default

NOS = New Old Stock. It means factory parts. If you can get them, you are usually way ahead of the game as far as quality goes compared to repop Chicom parts.

Did these symptoms present themselves before they replaced the switch 5 months ago and the problem went away?
fastbackford351 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kingofqueenz
4.6L (1996-2004 Modular) Mustang
21
03-18-2008 05:55 PM
jwoe
General Tech
4
08-04-2005 06:31 PM
mikeb0914
General Tech
3
05-27-2005 06:52 PM
mikeb0914
4.6L (1996-2004 Modular) Mustang
2
05-27-2005 02:50 PM
nhdungeonracer
5.0L (1979-1995) Mustang
5
06-11-2004 05:16 PM


Thread Tools
Search this Thread
Quick Reply: Dashboarard / gauge lights shut off while driving


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.