2018 gt350 replaced with ford performance recaro and airbag light is up - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > General Tech
Reload this Page >

2018 gt350 replaced with ford performance recaro and airbag light is up

General Tech Ask model specific questions in the appropriate category below. All other general questions within.

2018 gt350 replaced with ford performance recaro and airbag light is up

Reply

 
 
 
Old 04-16-2018, 06:02 PM
  #1  
xianxian
Thread Starter
 
Join Date: Sep 2017
Location: Michigan
Posts: 12
Default 2018 gt350 replaced with ford performance recaro and airbag light is up

Hi guys

So here is my problem, AM said the seat will fit on 2018 gt350 so i brought the car. The seat was for my 2015 mustang so i think i can reuse them so i brought a gt350. I sold my 15 mustang and my gt 350's recaro. After install, i found the airbag light is up(connected! i'm not that stupid). so what should i do?
And the ford performance guy said it only fit on 15-17 mustang!!!
And FYI, 15 mustang have 7 wires from the car, and gt350 only have 5



this is the connector from 15 mustang



The connector from gt350


connector from the ford performance seat





xianxian is offline  
Reply With Quote
Old 04-16-2018, 06:04 PM
  #2  
xianxian
Thread Starter
 
Join Date: Sep 2017
Location: Michigan
Posts: 12
Default

and not only this, they have a lot of stuff that had wrong information!
xianxian is offline  
Reply With Quote
Old 04-16-2018, 06:05 PM
  #3  
xianxian
Thread Starter
 
Join Date: Sep 2017
Location: Michigan
Posts: 12
Default

i spent almost 10k on AM for parts, and i will not do that anymore!!
xianxian is offline  
Reply With Quote
Old 04-16-2018, 06:10 PM
  #4  
xianxian
Thread Starter
 
Join Date: Sep 2017
Location: Michigan
Posts: 12
Default

if you wanna ask why i want to keep using these, because i spent 3k on the seat and you don't want to just sell them with old car
xianxian is offline  
Reply With Quote
Old 04-16-2018, 09:46 PM
  #5  
xianxian
Thread Starter
 
Join Date: Sep 2017
Location: Michigan
Posts: 12
Default


what can i say????
xianxian is offline  
Reply With Quote
Old 04-16-2018, 09:50 PM
  #6  
xianxian
Thread Starter
 
Join Date: Sep 2017
Location: Michigan
Posts: 12
Default


i believe lying to the customer is not good in the USA
xianxian is offline  
Reply With Quote
Old 04-17-2018, 06:27 AM
  #7  
JimC
Moderator
 
JimC's Avatar
 
Join Date: May 2006
Location: North Carolina
Posts: 7,112
Default

We get it, you are upset. But multiple threads about the same thing is just going to get tiresome for the rest of us, and violates the terms of service for the forum.
JimC is offline  
Reply With Quote
Old 04-17-2018, 06:33 AM
  #8  
JimC
Moderator
 
JimC's Avatar
 
Join Date: May 2006
Location: North Carolina
Posts: 7,112
Default

And did the seats fit? Yes, they mounted up. When you looked at the plugs you noticed that one had 5 wires and the other had 7 wires, yet you still just went ahead and plugged it in? Seems like at that point YOU should have realized that something wasn't right and figured out the correct pin connectors or made a call.
JimC is offline  
Reply With Quote
Old 04-17-2018, 07:18 AM
  #9  
xianxian
Thread Starter
 
Join Date: Sep 2017
Location: Michigan
Posts: 12
Default

Originally Posted by JimC View Post
And did the seats fit? Yes, they mounted up. When you looked at the plugs you noticed that one had 5 wires and the other had 7 wires, yet you still just went ahead and plugged it in? Seems like at that point YOU should have realized that something wasn't right and figured out the correct pin connectors or made a call.
i'm sorry to post in different area, just want more people to give me advice

so when i installed them and plugged it in, the airbag light is up, i tried to disconnect the battery to reset the system which did not work, and then i checked the connectors and found the connectors are different

And the guy from ford performance told me it only fit in 15-18 mustangs
xianxian is offline  
Reply With Quote
Old 04-17-2018, 07:20 AM
  #10  
xianxian
Thread Starter
 
Join Date: Sep 2017
Location: Michigan
Posts: 12
Default

Originally Posted by JimC View Post
And did the seats fit? Yes, they mounted up. When you looked at the plugs you noticed that one had 5 wires and the other had 7 wires, yet you still just went ahead and plugged it in? Seems like at that point YOU should have realized that something wasn't right and figured out the correct pin connectors or made a call.
and they have a lot of their products' info wrong!
xianxian is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MustangForums Editor
Mustang News, Concepts, Rumors & Discussion
1
10-27-2017 06:11 AM
MustangForums Editor
Mustang News, Concepts, Rumors & Discussion
1
12-28-2016 10:23 AM
MustangForums Editor
Mustang News, Concepts, Rumors & Discussion
0
07-27-2015 01:33 PM
572ysc
Parts For Sale
0
10-12-2011 09:28 AM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory