Smart Junction Box dying? - MustangForums.com



GT S197 General Discussion This section is for technical discussions pertaining specifically to the V8 variation of the 2005 and newer Ford Mustang.

Reply
 
 
 
Thread Tools Search this Thread
Old 08-20-2014, 06:39 PM   #1  
Kagnus
Thread Starter
 
Kagnus's Avatar
 
Join Date: Jul 2014
Location: Texas
Posts: 14
Default Smart Junction Box dying?

I have been having a problem with my drivers side window motor not getting any power. Master switch works fine as does the passenger side window motor. Tested for continuity between the switch and motor and motor and main fuse box @ fuse F5 with all testing good. However I do not how to test for continuity between the smart junction box and the window motor/master switch. That may be the next step, however I am certain that the window motor has power but whatever completes the circuit between the various functions seems to be faulting (the smart junction box?). I had water leaking in under the cowl due to some leaves plugging a drain a couple of years ago so I suspected it was just a corroded connection. So I unbolted the box and started disconnecting the relay bundles looking for problems and I SHOULD have disconnected the battery before I did this. Now after plugging everything back in my headlights and running lights will not turn off even after the keys are removed and I am getting sensor faults all over the place. [email protected]#$%^&*



Help.
Kagnus is offline   Reply With Quote
Old 09-27-2014, 06:09 PM   #2  
Kagnus
Thread Starter
 
Kagnus's Avatar
 
Join Date: Jul 2014
Location: Texas
Posts: 14
Default

anyone?
Kagnus is offline   Reply With Quote
Old 09-27-2014, 06:31 PM   #3  
Nuke
6th Gear Member
 
Nuke's Avatar
 
Join Date: Jun 2007
Location: PA to KY ('07) to IL ('09) to MS ('10) to FL ('11)
Posts: 16,186
Default

Wish I could provide some helpful info but I never had to pull my SJB; only dry it out once.
Nuke is offline   Reply With Quote
Old 09-27-2014, 06:41 PM   #4  
tbar
2nd Gear Member
 
Join Date: Mar 2011
Location: Canada
Posts: 159
Default

Have you tried disconnecting the battery for awhile since you plugged everything back in to the SJB?
tbar is offline   Reply With Quote
Old 09-27-2014, 08:23 PM   #5  
Kagnus
Thread Starter
 
Kagnus's Avatar
 
Join Date: Jul 2014
Location: Texas
Posts: 14
Default

Quote:
Originally Posted by tbar View Post
Have you tried disconnecting the battery for awhile since you plugged everything back in to the SJB?
yeah, same thing after reconnecting. I talked to some guys at a local autoshop and they didn't seem to understand what the SBJ is. They think it is just a regular fuse relay and it is really a little more than that. Sorta annoying...

This module requires programming if it is replaced correct?
Kagnus is offline   Reply With Quote
Old 09-28-2014, 09:25 AM   #6  
outceltj
5th Gear Member
 
outceltj's Avatar
 
Join Date: Sep 2010
Location: IN
Posts: 2,072
Default

I know in the past people have mentioned same kind of experience and it was alternator. Probably not the suggestion your looking for. Hopefully you can find some good advice
outceltj is offline   Reply With Quote
Old 09-29-2014, 12:34 PM   #7  
Dawghouse
2nd Gear Member
 
Join Date: Nov 2012
Location: GA
Posts: 293
Default

When my SJB went out my windows were fine the only thing that it affected was my Auto transmission it locked it in park and I had to use the emergency unlock feature to be able to drive anywhere. That is not to say that it is the only thing the SJB would effect just my experience with it. I took it to a dealer to have them trouble shoot the problem when I couldn't think of anything else (Thought my shifter had died).

And yes if you replace it, it will need to be programed.

Last edited by Dawghouse; 09-29-2014 at 04:20 PM.
Dawghouse is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Snow performance stage 2 MAF boos cooler install jwog666 Pipes, Boost & Juice 6 01-07-2018 07:16 AM
S197 Parts baddog671 Parts For Sale 20 07-26-2016 01:20 PM
What is the tube coming out of the air intake that goes to the small box? daltron 5.0L GT S550 Tech 17 04-28-2016 08:10 PM
Starting Issue svfetter 5.0L (1979-1995) Mustang 9 10-05-2015 11:39 AM
4r70w torque converter q's guitarman376 4.6L (1996-2004 Modular) Mustang 0 09-30-2015 05:54 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 10:10 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.