It might not be running right, but at least it looks good! - MustangForums.com



Members Mustangs This section is for picture threads relating to members Mustangs. Please read the rules before posting!

Reply
 
 
 
Thread Tools Search this Thread
Old 06-23-2014, 09:08 PM   #1
JimC
Moderator
Thread Starter
 
JimC's Avatar
 
Join Date: May 2006
Location: Michigan
Posts: 6,595
Default It might not be running right, but at least it looks good!

I added a turbo to the car, finished it May 1 and took it for one more test drive .......and broke something in the upper part of the engine. Still trying to determine what happened and why so the car, while driveable isn't really ready for the road.

I decided to give the car a wash and wax yesterday. It was pretty dirty and dusty from sitting in the shop and then in the garage. Pat used the leaf blower in the driveway and the car was covered, and then someone dragged something across the hood through the dust.

So wash with some Mother's wash, and then I used the Mother's Synthetic Wax on it. It was detailed in February for Autorama but I didn't drive it much after that. So wash and wax was all it needed. I forgot how much it takes on black to get it swirl free and looking good (hood stripe and rear spoiler are both painted black). Even though I haven't driven it much I couldn't believe how many little chips the front spoiler picked up already!







I'm going to have to detail the engine bay. Washed it but it needs some more attention.








And the gauge pack. I need to clean up the interior - I think that I will drive it the 1 mile to Northgate Ford and back on Friday for Blue Water Cruise Night



Last edited by JimC; 06-23-2014 at 09:12 PM.
JimC is offline   Reply With Quote
Old 06-24-2014, 02:47 AM   #2
Tanner05
Chop Mod
 
Tanner05's Avatar
 
Join Date: Sep 2010
Location: OK
Posts: 3,330
Default

It looks awesome, Jim. Btw, I nominated you in Ride of the Month. Just a heads up in case you don't go in that section very often.
Tanner05 is offline   Reply With Quote
Old 06-24-2014, 02:16 PM   #3
JimC
Moderator
Thread Starter
 
JimC's Avatar
 
Join Date: May 2006
Location: Michigan
Posts: 6,595
Default

Thanks. I don't get to that section often
JimC is offline   Reply With Quote
Old 06-24-2014, 08:06 PM   #4
Soldier GT
6th Gear Member
 
Soldier GT's Avatar
 
Join Date: Aug 2007
Location: MO/ Born and raised in Louisiana
Posts: 10,693
Default

I feel your pain my man. Car looks great tho!
Soldier GT is offline   Reply With Quote
Old 08-05-2014, 09:59 PM   #5
ChicagoWendy
 
ChicagoWendy's Avatar
 
Join Date: Jul 2014
Location: Illinois
Posts: 17
Default

I can tell that you love your baby. It is beautiful!
ChicagoWendy is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
New member and restomod brake booster/mc advice needed Faolan65 New Member Area 2 08-27-2015 06:40 AM
New member and restomod brake booster/mc advice needed Faolan65 Arizona Regional Chapter 0 08-25-2015 09:24 AM
1992 Summer Edition - Wont start! labudski 5.0L (1979-1995) Mustang 2 08-24-2015 07:23 AM
New guy from MN Stilz New Member Area 3 08-19-2015 06:17 AM
Need Help Diagnosing Have Codes (Confused) djbigskrilla 2005-2014 Mustangs 13 08-11-2015 12:59 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 10:44 AM.