clunking from front after springs/shots - Page 2 - MustangForums.com



S197 Handling Section For everything suspension related, inlcuding brakes, tires, and wheels.
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 08-22-2011, 09:45 AM   #11
tigercrazy718
4th Gear Member
Thread Starter
 
Join Date: Mar 2009
Location: Houston, Texas
Posts: 1,731
Default

Quote:
Originally Posted by 2005Redfire6 View Post
I think its your sway bar endlinks as well, I had the same issue but not after the first time of taking it off and putting them back. Mine started clunking after the 2-3 time I took them off for various reasons because the bolt stretched I guess, ended up getting the Steeda ones.
alright will do. i cant remember am i gonna be able to reach the bolts without taking the wheels off?
tigercrazy718 is offline   Reply With Quote
Old 08-22-2011, 10:20 AM   #12
Norm Peterson
6th Gear Member
 
Norm Peterson's Avatar
 
Join Date: Feb 2007
Location: state of confusion
Posts: 7,400
Default

Unless you have access to a lift, it'll be a lot easier if you do pull a wheel. One wheel off at a time, please.


Norm
Norm Peterson is offline   Reply With Quote
Old 08-22-2011, 12:18 PM   #13
tigercrazy718
4th Gear Member
Thread Starter
 
Join Date: Mar 2009
Location: Houston, Texas
Posts: 1,731
Default

Quote:
Originally Posted by Norm Peterson View Post
Unless you have access to a lift, it'll be a lot easier if you do pull a wheel. One wheel off at a time, please.


Norm
alright sounds good
tigercrazy718 is offline   Reply With Quote
Old 09-22-2011, 11:29 PM   #14
tigercrazy718
4th Gear Member
Thread Starter
 
Join Date: Mar 2009
Location: Houston, Texas
Posts: 1,731
Default

ok so took my car to a stang shop and what was wrong is that the stuff you had to double wrench wasnt tight enough. thanks for the suggestions guys and some of yall were right but i just didnt have the tools to tighten it up enough. still saved alot of money on the install tho lol. car rides like a dream now
tigercrazy718 is offline   Reply With Quote
Old 09-24-2011, 11:20 AM   #15
157dB
Cut & Paste Expert
 
157dB's Avatar
 
Join Date: May 2007
Location: NW Arkansas
Posts: 13,322
Default

It could just be increased NVH from the spherical CC plates.
But the sway bar link has been known to come loose on Konis
and its the simplest thing to check first...
157dB is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
WTB Kona Blue GT Front Bumper Cover winner99 Want To Buy Ads 0 10-01-2015 02:06 PM
WTB 11-14 GT Front OEM Sway Bar winner99 Want To Buy Ads 0 10-01-2015 11:52 AM
Colgan Custom Bra for 2014 Mustang mdg Parts For Sale 0 10-01-2015 08:04 AM
GT500 front LCA question UrS4 S197 Handling Section 1 09-30-2015 11:13 AM
Car Suspension problems? marc954 4.6L (1996-2004 Modular) Mustang 2 09-29-2015 12:18 PM


Tags
20052009, bar, bump, bumps, clunk, clunking, front, hit, hr, lift, lowered, mustang, rebuilt, speed, springs, suspension, sway

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 10:46 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.