Suspension upgrades now getting a thump, thump. - MustangForums.com



S197 Handling Section For everything suspension related, inlcuding brakes, tires, and wheels.
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 01-22-2014, 02:23 PM   #1
Matt's 95 Stang
Resident Ginger
Thread Starter
 
Matt's 95 Stang's Avatar
 
Join Date: Nov 2006
Location: Cali
Posts: 4,623
Default Suspension upgrades now getting a thump, thump.

So I finally installed my BMR non adj LCA, relo brackets, PHB and brace, Eibach pro kit springs, anti roll bar kit, and Koni struts/shocks and I'm getting a thump, thump, during turns coming from the driver rear. I TQed everything with the suspension under load so looking for ideas on what it could be.

Sound only comes when making slow turns. It does not sound like metal hitting metal. More like a dull thump, then half second later, thump.

Any ideas?

Thanks
Matt's 95 Stang is offline   Reply With Quote
Old 01-22-2014, 08:08 PM   #2
808muscle
5th Gear Member
 
808muscle's Avatar
 
Join Date: Oct 2009
Location: Maui
Posts: 4,752
Default

Any chance your missing a bushing? Any chance something is in backwards therefore causing a rub and knock?
808muscle is offline   Reply With Quote
Old 01-22-2014, 09:05 PM   #3
MustangVixenGT
2nd Gear Member
 
MustangVixenGT's Avatar
 
Join Date: Oct 2013
Location: Washington
Posts: 287
Default

I had that issue with my BMR suspension but it was the sway bar it had come loose. Is your PHB adjustable?
MustangVixenGT is offline   Reply With Quote
Old 01-23-2014, 08:04 AM   #4
Matt's 95 Stang
Resident Ginger
Thread Starter
 
Matt's 95 Stang's Avatar
 
Join Date: Nov 2006
Location: Cali
Posts: 4,623
Default

Quote:
Originally Posted by 808muscle View Post
Any chance your missing a bushing? Any chance something is in backwards therefore causing a rub and knock?
I honestly don't remember how the bushing on the shocks are suppose to go (it looks rather self explanatory to me but that doesn't mean I did it right) but they look right.

Is there a chance? Always. Do I think I did install something backwards? No. Sway bar, shocks, LCA's, PHB brace, relocation brackets can only be installed one way. I did install the PHB the opposite way that Steeda has theirs due to the zerks fittings only being accessible one way.

Quote:
Originally Posted by MustangVixenGT View Post
I had that issue with my BMR suspension but it was the sway bar it had come loose. Is your PHB adjustable?
Yeah I have the adj. BMR bar. Ill check to see if it came loose.

I purposely didn't post in the handling section as it doesn't get as much traffic but oh well.
Matt's 95 Stang is offline   Reply With Quote
Old 01-23-2014, 09:43 AM   #5
BrazenStang
3rd Gear Member
 
Join Date: Sep 2011
Location: DE
Posts: 546
Default

Hey Matt, What about the handbrake cable? If that is not secured, or was not put back correctly that could slap around. Otherwise, it would be good to re-read the directions and maybe you missed something?
BrazenStang is offline   Reply With Quote
Old 01-23-2014, 10:50 AM   #6
Matt's 95 Stang
Resident Ginger
Thread Starter
 
Matt's 95 Stang's Avatar
 
Join Date: Nov 2006
Location: Cali
Posts: 4,623
Default

Quote:
Originally Posted by BrazenStang View Post
Hey Matt, What about the handbrake cable? If that is not secured, or was not put back correctly that could slap around. Otherwise, it would be good to re-read the directions and maybe you missed something?
Handbrake/E brake cable is secure to the LCA's like directions instructed me to do I know its not that. I havent put the car back up on jacks yet to poke around but sounds like I am going to have to.

Matthew
Matt's 95 Stang is offline   Reply With Quote
Old 01-23-2014, 11:45 AM   #7
Allupinya
2nd Gear Member
 
Join Date: Jul 2013
Location: The Ring
Posts: 225
Default

have you talked to the company you bought the stuff from, they might be able to help you.
Allupinya is offline   Reply With Quote
Old 01-23-2014, 06:46 PM   #8
MustangVixenGT
2nd Gear Member
 
MustangVixenGT's Avatar
 
Join Date: Oct 2013
Location: Washington
Posts: 287
Default

Yeah good chance its that, shop that does a lot of my work have said they have seen it happen on quite a few of the S197's with that setup. Be a good place to start anyhow.
MustangVixenGT is offline   Reply With Quote
Old 01-24-2014, 08:21 AM   #9
Matt's 95 Stang
Resident Ginger
Thread Starter
 
Matt's 95 Stang's Avatar
 
Join Date: Nov 2006
Location: Cali
Posts: 4,623
Default

Quote:
Originally Posted by Allupinya View Post
have you talked to the company you bought the stuff from, they might be able to help you.
I have three different manufactures (Eibach, BMR, and Koni) so until I can find where the noise is coming from it doesn't do much good to call yet.

Quote:
Originally Posted by MustangVixenGT View Post
Yeah good chance its that, shop that does a lot of my work have said they have seen it happen on quite a few of the S197's with that setup. Be a good place to start anyhow.
Are you talking about the PHB coming loose still? I am going to get my 4 wheel alignment done today after work so I planned on having the shop look into when they have it on the lift.

Matthew
Matt's 95 Stang is offline   Reply With Quote
Old 01-24-2014, 09:51 AM   #10
157dB
Cut & Paste Expert
 
157dB's Avatar
 
Join Date: May 2007
Location: NW Arkansas
Posts: 13,322
Default

Did you torque all the fasteners with the suspension loaded at ride height?
Torquing with a fully drooped suspension will cause all sorts of problems you do not need...
157dB is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Upgraded PaulH2 Members Rides and Car Show Section 20 01-31-2016 09:48 AM
UPR Products Rockin the Lethal Performance Grille Delete Combo! Boostaddict Lethal Performance 0 10-01-2015 08:58 AM
UPR Products Rockin the Lethal Performance Grille Delete Combo! Boostaddict 3.7L V6 S550 Tech 0 10-01-2015 08:57 AM
GT500 front LCA question UrS4 S197 Handling Section 1 09-30-2015 10:13 AM
Car Suspension problems? marc954 4.6L (1996-2004 Modular) Mustang 2 09-29-2015 11:18 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 06:34 PM.