MustangForums.com - Search Results

Go Back  MustangForums.com > Search Forums
Reload this Page >

Search Results

 
Search: Posts Made By: lxman1
Showing results 1 to 25 of 497
Search took 0.32 seconds.
06-13-2018, 03:48 PM
Replies: 2
Views: 815
Posted By lxman1

Welcome to the forum. The 1406 uses the same...

Welcome to the forum.

The 1406 uses the same diameter for the air cleaner base as the Holley does.
I have only put shorties on my 88 LX, but the chassis is the same, with no clearance issues....
03-30-2018, 02:27 PM
Replies: 4
Views: 358
Posted By lxman1

I have never seen a Foxbody with a power sunroof,...

I have never seen a Foxbody with a power sunroof, many manual ones.
02-27-2017, 11:44 AM
Replies: 4
Views: 369
Posted By lxman1

Use a good thread sealer on the threads, not RTV.

Use a good thread sealer on the threads, not RTV.
02-27-2017, 11:39 AM
Replies: 9
Views: 682
Posted By lxman1

How old is the IAC? It may be sticking or too...

How old is the IAC? It may be sticking or too slow to keep up with the idle needed
12-09-2016, 04:00 PM
Replies: 4
Views: 474
Posted By lxman1

Personally, I would go TrickFlow Stage 1 over the...

Personally, I would go TrickFlow Stage 1 over the letter cams, but that's just my personal opinion..
02-17-2015, 01:51 PM
Replies: 10
Views: 631
Posted By lxman1

Glad I have the Trickflow TrackHeat.

Glad I have the Trickflow TrackHeat.
02-17-2015, 01:32 PM
Replies: 15
Views: 920
Posted By lxman1

I couldn't use a BBK regulator with my TrackHeat...

I couldn't use a BBK regulator with my TrackHeat intake on the stock fuel rails. The OD was too big and hit the upper intake. I ended up using a Holley adjustable regulator which is the same size as...
06-14-2014, 04:36 PM
Replies: 22
Views: 2,289
Posted By lxman1

Temp gauge on mine (verified with a mechanical...

Temp gauge on mine (verified with a mechanical gauge)

The first line up above the bottom(130) is 160*
The second line up is 180*
the bottom of the M is 195* which is where mine runs now.

The...
05-24-2014, 08:27 PM
Replies: 14
Views: 2,082
Posted By lxman1

I like it. The 2.95 first gear works well with my...

I like it. The 2.95 first gear works well with my 3.73's. The trans feels more like an old close ratio toploader or Mucie M-22. If I shift from 1st to second at 4000rpm, it drops to only about...
05-22-2014, 03:31 PM
Replies: 14
Views: 2,082
Posted By lxman1

Runs a lot better now. Just installed a new World...

Runs a lot better now. Just installed a new World Class T-5 and when I get some miles on it, I am heading back to the track to see what happens. Still getting used to the 2.95 1st gear vs the old...
03-31-2014, 09:11 PM
Replies: 14
Views: 2,082
Posted By lxman1

Just an update, the guy that I bought the engine...

Just an update, the guy that I bought the engine from had put the cam in 4* advanced and it was off a tooth from that. Installed a new CompCams double roller timing set straight up and it is back to...
03-31-2014, 09:05 PM
Replies: 3
Views: 455
Posted By lxman1

The lighter has a round center post with a 90...

The lighter has a round center post with a 90 degree plug like the one on the temp sending unit on the intake manifold. It also has a Spade terminal on the outer body for a ground. One of them...
03-31-2014, 09:01 PM
Replies: 18
Views: 1,097
Posted By lxman1

Sure you have it wired as a 302 HO and not a 302...

Sure you have it wired as a 302 HO and not a 302 non-HO? The HO uses a 351W firing order.

The pick-up coil in the dizzy can be bad too.
12-31-2013, 03:19 PM
Replies: 7
Views: 596
Posted By lxman1

Too much side stepping of the clutch since it is...

Too much side stepping of the clutch since it is my left foot :D
12-28-2013, 04:06 PM
Replies: 7
Views: 596
Posted By lxman1

Thanks, I will give it a try when I can walk on...

Thanks, I will give it a try when I can walk on my broken foot again.
12-21-2013, 10:30 AM
Replies: 7
Views: 596
Posted By lxman1

It is running lean, even when I crank up the fuel...

It is running lean, even when I crank up the fuel pressure to 60psi. It doesn't want to idle cold and had a lean miss at part throttle when driving. The plugs look brand new. Too clean.
It was fine...
12-20-2013, 02:19 PM
Replies: 7
Views: 596
Posted By lxman1

Vacuum leak

Has anyone else had any issues with the TrickFlow Track heat intake not sealing off completely?
I have a vacuum leak somewhere in the intake but have been unsuccessful finding it. I have had the...
12-20-2013, 02:08 PM
Replies: 7
Views: 1,794
Posted By lxman1

Something bad is definitely going on in there. ...

Something bad is definitely going on in there.

Like mentioned above, any loss of oil pressure? Any valvetrain noise?

Since you have the balancer off, go ahead and pull the timing cover and...
11-04-2013, 01:06 PM
Replies: 11
Views: 1,449
Posted By lxman1

Perhaps the smog pump pipe is not connected and...

Perhaps the smog pump pipe is not connected and it just blowing air into the atmosphere?
09-18-2013, 12:56 AM
Replies: 2
Views: 527
Posted By lxman1

The Explorer is probably OBD-II where the 95 V8...

The Explorer is probably OBD-II where the 95 V8 cars are OBD-I I believe. You would have to rewire under the hood and need something in the block to turn the oil pump as well.

I agree on leaving...
09-18-2013, 12:51 AM
Replies: 5
Views: 404
Posted By lxman1

85/86 T-Top cars are more common than most other...

85/86 T-Top cars are more common than most other years. At least they are around here. I know that 88 was the last year for T-Tops.
09-18-2013, 12:49 AM
Replies: 4
Views: 420
Posted By lxman1

This on a 95 correct? Why do you want to advance...

This on a 95 correct? Why do you want to advance the cam?
09-18-2013, 12:46 AM
Replies: 5
Views: 913
Posted By lxman1

Turn signals, emergency flashers, hi-beam...

Turn signals, emergency flashers, hi-beam headlights and windshield wipers/washer are all controlled by the multi-function switch.

Also check the connector plug, sometimes they get hot and melt a...
09-18-2013, 12:43 AM
Replies: 6
Views: 340
Posted By lxman1

Mine had a vibration at 75-up. Found out the...

Mine had a vibration at 75-up. Found out the driveshaft was bent a bit. (Was a good excuse to buy a Ford Racing aluminum driveshaft)
Have the tires balanced. Check for play in the u-joints. Jack...
09-18-2013, 12:33 AM
Replies: 13
Views: 782
Posted By lxman1

Sounds like a bad sending unit or there is an air...

Sounds like a bad sending unit or there is an air pocket in the cooling system and coolant isn't always hitting the sending unit.
Showing results 1 to 25 of 497
 


 
Forum Jump

Advertising
Featured Sponsors
Vendor Directory