Ok my PCM is bad - MustangForums.com

Notices
V6 (1994-2004) Mustangs Technical discussions on the 3.8L and 3.9L V6 torque monsters

Ok my PCM is bad

Reply

 
 
 
Old 09-28-2008, 03:29 AM
  #1  
RoBDoG
2nd Gear Member
Thread Starter
 
RoBDoG's Avatar
 
Join Date: Mar 2008
Location:
Posts: 294
Angry Ok my PCM is bad

i ran the hard reset on the stang and the engine light popped up about 10-15 miles down the road. Would this pcm degrade my performance at all w/ a malfunctioning pcm i have now. Cause its saying my o2 sensor is bad but it inst its been replaced twice. So bank 2 side is running lean. Should i get a new pcm to help my performance because im running lean and my gas mileage has gone down and so has performance. I know someone in the forums thats selling the exact one i need. any input would be great ... thanks
RoBDoG is offline  
Reply With Quote
Old 09-28-2008, 03:34 AM
  #2  
volcomchester18
3rd Gear Member
 
Join Date: Aug 2004
Location: Orange county, CA
Posts: 505
Default

depending on the code it could decrease your performance, plus you might be getting less mpgs. If you keep getting the same code for 02 sensor, either your pcm is malfunctioning like you say, or the 02 sensors are getting damaged by a rich combustion ( I cant remember excatly if thats the reason for 02 sensor failure). Best bet is that you get that ecu and see what happens, make sure its for a 5 spd.

Last edited by volcomchester18; 09-28-2008 at 03:36 AM.
volcomchester18 is offline  
Reply With Quote
Old 09-28-2008, 10:42 AM
  #3  
03sixbanger
Ryan's Backup Mod
 
03sixbanger's Avatar
 
Join Date: Jul 2006
Location: Lafayette,TN
Posts: 3,320
Default

if you get the computer remember its not just a swap and go....you will have to take it to ford
03sixbanger is offline  
Reply With Quote
Old 09-28-2008, 11:45 AM
  #4  
RED2000
2nd Gear Member
 
Join Date: Jun 2007
Location: Muskegon, MI
Posts: 466
Default

pcm's rarely go bad. just get a tuner and turn off the oxygen sensors and you get your "performance" back with a tune
RED2000 is offline  
Reply With Quote
Old 09-28-2008, 03:05 PM
  #5  
RyansQuick6
Reverse Gear Member
 
RyansQuick6's Avatar
 
Join Date: Dec 2006
Location: Baton Rouge, LA
Posts: 8,130
Default

The PCM isn't your problem, it's almost impossible for them to fail without physical contact with and impact or water.

Instead of replacing a part that works fine, try cleaning out your MAF. If you put a bosch sensor in their, then it will never work right, you have to get the ford one
RyansQuick6 is offline  
Reply With Quote
Old 09-28-2008, 09:27 PM
  #6  
RoBDoG
2nd Gear Member
Thread Starter
 
RoBDoG's Avatar
 
Join Date: Mar 2008
Location:
Posts: 294
Default

alright, yes it is a bosch one. I'll have to find the receipt and return the stupid thing a 2nd time lol. I'll just buy one from ford and reinstall it reset the comp. and see whats up, i also have clean the maf.
RoBDoG is offline  
Reply With Quote
Old 09-28-2008, 11:32 PM
  #7  
volcomchester18
3rd Gear Member
 
Join Date: Aug 2004
Location: Orange county, CA
Posts: 505
Default

Originally Posted by RyansQuick6 View Post
The PCM isn't your problem, it's almost impossible for them to fail without physical contact with and impact or water.

Instead of replacing a part that works fine, try cleaning out your MAF. If you put a bosch sensor in their, then it will never work right, you have to get the ford one
for the record, pcms do go bad sometimes I replaced a few faulty ones, but yes it is very rare. But since you say that the bosch sensors suck, then that probably makes sense. Bosch doesnt make good spark plugs either, how weird.
volcomchester18 is offline  
Reply With Quote
Old 09-29-2008, 01:16 AM
  #8  
RoBDoG
2nd Gear Member
Thread Starter
 
RoBDoG's Avatar
 
Join Date: Mar 2008
Location:
Posts: 294
Default

Originally Posted by volcomchester18 View Post
for the record, pcms do go bad sometimes I replaced a few faulty ones, but yes it is very rare. But since you say that the bosch sensors suck, then that probably makes sense. Bosch doesnt make good spark plugs either, how weird.
lol i know i was hesitent when they said bosch... orignal equipment i was like ok w/e i want this fixed now i hate bosch more than anything i thougth it wsa just their plugs O WELL lol
RoBDoG is offline  
Reply With Quote
Old 09-29-2008, 03:08 AM
  #9  
cuban tech
1st Gear Member
 
cuban tech's Avatar
 
Join Date: Aug 2008
Location: Chicago
Posts: 120
Default

if i remember the 02 sensor's from ford are not bosch. But i don't look at the part name.
cuban tech is offline  
Reply With Quote
Old 09-29-2008, 07:20 AM
  #10  
RyansQuick6
Reverse Gear Member
 
RyansQuick6's Avatar
 
Join Date: Dec 2006
Location: Baton Rouge, LA
Posts: 8,130
Default

I think that they might actually be a Delphi product or something like that. When I was working for Ford, and GM, and Chrysler, it was amazing to see who the OE manufacturer was on a lot of the stuff. Toyota is the only one that pretty much makes all their stuff themselves.

I used to love it when we'd use another manufacturers products on different vehicles or when GM and CHrysler recommend the Ford part number for friction modifier in an LSD lol
RyansQuick6 is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Dathan
V6 (1994-2004) Mustangs
4
10-05-2015 06:52 AM
KingRando
2005-2014 Mustangs
5
10-02-2015 09:06 AM
ChampInSD
5.0L GT S550 Tech
13
10-02-2015 05:55 AM
UrS4
S197 Handling Section
1
09-30-2015 11:13 AM
GLOCKer
General Tech
0
09-28-2015 08:36 AM


Thread Tools
Search this Thread
Quick Reply: Ok my PCM is bad


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.