Blinker Messed Up? - MustangForums.com


V6 S197 General Discussion This section is for technical discussions pertaining specifically to the V6 variation of the 2005 and newer Ford Mustang.
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 10-13-2006, 07:21 PM   #1  
HurricaneStang
4th Gear Member
Thread Starter
 
Join Date: Jun 2006
Location:
Posts: 1,165
Default Blinker Messed Up?

Hey, i was on my way home today and for some reason my right turn blinker goes way faster then the left one. The left one still blinks normally and the hazards blink at the same pace so i dont understand why the right turn is going alot faster. Any ideas? Thanks
HurricaneStang is offline   Reply With Quote
Old 10-13-2006, 07:29 PM   #2  
AmericanICON
3rd Gear Member
 
Join Date: Jun 2006
Location: Omaha, Nebraska
Posts: 861
Default RE: Blinker Messed Up?

One of your bulbs are out. Inspect all your lights. Have someone look at the rear of your car as you step on the brakes. Although a rear bulb lights up when you turn it on, there's a possility that one doesn't work when you step on the brake.
AmericanICON is offline   Reply With Quote
Old 10-14-2006, 12:32 PM   #3  
dram57
1st Gear Member
 
Join Date: May 2006
Location:
Posts: 60
Default RE: Blinker Messed Up?

That's usually a sign of a burned out bulb or less likely
wire short.
dram57 is offline   Reply With Quote
Old 10-14-2006, 12:34 PM   #4  
joshetc
2nd Gear Member
 
Join Date: Jul 2006
Location:
Posts: 242
Default RE: Blinker Messed Up?

Interesting cause from time to time I get the same thing, right one goes about 2x as fast as the left. Even more interesting is all of my bulbs seem to be perfectly fine?
joshetc is offline   Reply With Quote
Old 10-14-2006, 03:08 PM   #5  
Sick Six
2nd Gear Member
 
Join Date: Aug 2006
Location: Trinity, Tx
Posts: 381
Default RE: Blinker Messed Up?

That happened to me one time, and I checked and one
of the bulbs was out, I've also seen a lot of other stangs
with bulbs out and even the lights blink faster. If all your bulbs are
fine then its probably a short or something.
Sick Six is offline   Reply With Quote
Old 10-14-2006, 04:38 PM   #6  
pony girl 05
3rd Gear Member
 
Join Date: May 2006
Location:
Posts: 533
Default RE: Blinker Messed Up?

Dam, I actually knew the answer to this one, and I was beat to it by like 4 people. Oh well some day I will get better at these questions it will just take me a bit
pony girl 05 is offline   Reply With Quote
Old 10-14-2006, 07:05 PM   #7  
HurricaneStang
4th Gear Member
Thread Starter
 
Join Date: Jun 2006
Location:
Posts: 1,165
Default RE: Blinker Messed Up?

Well after a long nights rest the blinker is back to normal. Checked for the bulbs being out and there wasnt any so i guess it was just some kind of thing that happened Either way im still happy cuz now im not annoyed when i make a right turn
HurricaneStang is offline   Reply With Quote
Old 10-14-2006, 07:11 PM   #8  
stratjakt
2nd Gear Member
 
Join Date: Aug 2006
Posts: 205
Default RE: Blinker Messed Up?

Sounds like you're low on blinker fluid, you should check it and top it off if necessary.
stratjakt is offline   Reply With Quote
Old 10-15-2006, 04:36 AM   #9  
HurricaneStang
4th Gear Member
Thread Starter
 
Join Date: Jun 2006
Location:
Posts: 1,165
Default RE: Blinker Messed Up?

Ahhh i didnt think about that. Ill check it out tomorrow
HurricaneStang is offline   Reply With Quote
Old 10-15-2006, 06:42 PM   #10  
BHRS
1st Gear Member
 
Join Date: Sep 2006
Location:
Posts: 119
Default RE: Blinker Messed Up?

Has the car been in the rain? Maybe just washed? If so one of the connections probably got wet. If it happens again unplug the wires from the front and rear lights and look for moisture. If you do not find anything, check the wiring under the hood.

If the plug is corroded you will find a white powder at the connection. Clean it with a wire brush or maybe a toothbrush-then apply a dielectric grease. This will protect it and stop the corrosion.

Good Luck....
BHRS is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
04 Mach 460 system, Installed Aftermarket HU, No Highs/Tweeters breaking Audio/Visual Electronics 5 10-02-2015 01:27 PM
When would you tune? firecoyote The New S550 2015-2017 Mustang 28 09-27-2015 02:37 PM
Will not fire up Wombatnation 5.0L (1979-1995) Mustang 12 09-13-2015 09:16 PM
96 V6 Gauges (Temp) 96stang3.8 V6 (1994-2004) Mustangs 1 09-10-2015 06:42 AM
Is This The Passive Anti-Theft Kicking In? stormesixx General Tech 1 08-25-2015 09:11 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 05:24 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.