2013 Mustang GT Turn Signals - Page 2 - MustangForums.com



2005-2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 09-12-2013, 04:51 PM   #11
Stangs4me
1st Gear Member
 
Join Date: Jul 2003
Location: United States
Posts: 50
Default

Just did mine. Check them out.

Stangs4me is offline   Reply With Quote
Old 09-12-2013, 04:53 PM   #12
Stangs4me
1st Gear Member
 
Join Date: Jul 2003
Location: United States
Posts: 50
Default

One more

Stangs4me is offline   Reply With Quote
Old 11-03-2013, 12:39 PM   #13
stang8psi
1st Gear Member
 
stang8psi's Avatar
 
Join Date: Jun 2006
Location:
Posts: 91
Default

7440 or 7443?
stang8psi is offline   Reply With Quote
Old 11-03-2013, 12:41 PM   #14
Stangs4me
1st Gear Member
 
Join Date: Jul 2003
Location: United States
Posts: 50
Default

They're 7443
Stangs4me is offline   Reply With Quote
Old 12-23-2013, 01:30 PM   #15
Mdelongpre
 
Join Date: Dec 2013
Location: Tx
Posts: 4
Default

I registered just to say that I got the ones from autoillumination (7443 bulbs) and they DO NOT FIT. I was the one on stangmods that said those don't fit either. I haven't tried 7440 bulbs so I'm hoping they work.
Mdelongpre is offline   Reply With Quote
Old 12-23-2013, 01:42 PM   #16
Stangs4me
1st Gear Member
 
Join Date: Jul 2003
Location: United States
Posts: 50
Default

'13-'14 is most definitely 7443. It is a dual-filament bulb. One filament is used for turn-signal and other for lock/unlock doors indication.
Stangs4me is offline   Reply With Quote
Old 12-24-2013, 11:22 AM   #17
Mdelongpre
 
Join Date: Dec 2013
Location: Tx
Posts: 4
Default

Well now two sets of bulbs from different sources do not fit, so this makes zero sense.
Mdelongpre is offline   Reply With Quote
Old 12-25-2013, 04:11 PM   #18
Black Beauty 09
Thread Starter
 
Join Date: Jan 2010
Location: NJ
Posts: 8
Default

Quote:
Originally Posted by Mdelongpre View Post
Well now two sets of bulbs from different sources do not fit, so this makes zero sense.
You did the ones from autolumination? The 7440s? They worked fine in my 2013.
Black Beauty 09 is offline   Reply With Quote
Old 12-26-2013, 08:41 AM   #19
Mdelongpre
 
Join Date: Dec 2013
Location: Tx
Posts: 4
Default

Quote:
Originally Posted by Black Beauty 09 View Post
You did the ones from autolumination? The 7440s? They worked fine in my 2013.
I did the 7443s because of what stangs4me said a couple posts up, but now I'm going to order the 7440s
Mdelongpre is offline   Reply With Quote
Old 12-27-2013, 03:37 PM   #20
Stangs4me
1st Gear Member
 
Join Date: Jul 2003
Location: United States
Posts: 50
Default

What exactly do you mean by not fitting??? 7440 and 7443 are identical sockets. The only difference is that 7440 has only 2 wires (being single-filament) and 7443 has 4 (dual filament). There is absolutely NO distinction between the actual plastic socket.
Stangs4me is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1989 starting problems, engine won't turn over. KEM Motorworks 5.0L (1979-1995) Mustang 20 08-14-2015 11:13 PM
Need Help Diagnosing Have Codes (Confused) djbigskrilla 2005-2014 Mustangs 13 08-11-2015 01:59 PM
Just swapped motor exhaust want fit daytooday Motor Swap Section 2 08-11-2015 10:22 AM
Just Bought a Fox cema93 5.0L (1979-1995) Mustang 13 08-10-2015 10:35 PM
351 losing electrical power 89blueslug General Tech 1 08-10-2015 08:20 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 06:19 AM.